{"answers":{"affected":"6 open source packages ship an affected version, including org.apache.pulsar:pulsar. It affects 1 product.","exploited":"There is no known exploitation of CVE-2022-24280 in the wild and no public exploit code.","fix":"Upgrade org.apache.pulsar:pulsar to a fixed version for your release line: 2.7.5, 2.8.3 or 2.9.2.","what":"CVE-2022-24280 is a medium-severity server-side request forgery vulnerability in Apache Pulsar, published on 23 Sep 2022. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2022-24280 and fix it if it is affected.\n\nWhat it is: CVE-2022-24280 is a medium-severity server-side request forgery vulnerability in Apache Pulsar, published on 23 Sep 2022. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2022-24280 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.apache.pulsar:pulsar (Maven): affected all versions; fixed in 2.7.5\n- org.apache.pulsar:pulsar (Maven): affected all versions; fixed in 2.7.5\n- org.apache.pulsar:pulsar (Maven): affected from 2.8.0; fixed in 2.8.3\n- org.apache.pulsar:pulsar (Maven): affected from 2.8.0; fixed in 2.8.3\n- org.apache.pulsar:pulsar (Maven): affected from 2.9.0; fixed in 2.9.2\n- org.apache.pulsar:pulsar (Maven): affected from 2.9.0; fixed in 2.9.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-24280/ (Markdown: https://insights.sbomify.com/CVE-2022-24280/index.md)","id":"CVE-2022-24280","markdown":"https://insights.sbomify.com/CVE-2022-24280/index.md","name":"CVE-2022-24280","record":{"aliases":["GHSA-3mg9-m3f6-v7fq"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Apache Pulsar Proxy","requires_auth":"low_privilege","summary":"An attacker with a valid token can force the Pulsar Proxy to initiate TCP connections to arbitrary addresses, enabling Denial of Service attacks.","user_interaction":"not_required","vuln_class":"ssrf"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"apache","cpe":[{"product":"pulsar","vendor":"apache"}],"cvss":{"score":6.5,"severity":"medium","source":"cisa-adp","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H","version":"3.1"},"cwes":[{"id":"CWE-20","name":"Improper Input Validation"}],"description":"Improper Input Validation vulnerability in Proxy component of Apache Pulsar allows an attacker to make TCP/IP connection attempts that originate from the Pulsar Proxy's IP address. When the Apache Pulsar Proxy component is used, it is possible to attempt to open TCP/IP connections to any IP address and port that the Pulsar Proxy can connect to. An attacker could use this as a way for DoS attacks that originate from the Pulsar Proxy's IP address. It hasn’t been detected that the Pulsar Proxy authentication can be bypassed. The attacker will have to have a valid token to a properly secured Pulsar Proxy. This issue affects Apache Pulsar Proxy versions 2.7.0 to 2.7.4; 2.8.0 to 2.8.2; 2.9.0 to 2.9.1; 2.6.4 and earlier.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Apache Pulsar Proxy target broker address isn't validated","id":"CVE-2022-24280","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"ssrf","year":"2022"},"n_packages":6,"n_references":1,"next":{"headline":"SQL injection in SINEC NMS","id":"CVE-2022-24281"},"packages":[{"ecosystem":"Maven","fixed":["2.7.5"],"introduced":["0"],"last_affected":[],"package":"org.apache.pulsar:pulsar","purl":null,"source":"GHSA-3mg9-m3f6-v7fq"},{"ecosystem":"Maven","fixed":["2.7.5"],"introduced":["0"],"last_affected":[],"package":"org.apache.pulsar:pulsar","purl":"pkg:maven/org.apache.pulsar/pulsar","source":"GHSA-3mg9-m3f6-v7fq"},{"ecosystem":"Maven","fixed":["2.8.3"],"introduced":["2.8.0"],"last_affected":[],"package":"org.apache.pulsar:pulsar","purl":null,"source":"GHSA-3mg9-m3f6-v7fq"},{"ecosystem":"Maven","fixed":["2.8.3"],"introduced":["2.8.0"],"last_affected":[],"package":"org.apache.pulsar:pulsar","purl":"pkg:maven/org.apache.pulsar/pulsar","source":"GHSA-3mg9-m3f6-v7fq"},{"ecosystem":"Maven","fixed":["2.9.2"],"introduced":["2.9.0"],"last_affected":[],"package":"org.apache.pulsar:pulsar","purl":null,"source":"GHSA-3mg9-m3f6-v7fq"},{"ecosystem":"Maven","fixed":["2.9.2"],"introduced":["2.9.0"],"last_affected":[],"package":"org.apache.pulsar:pulsar","purl":"pkg:maven/org.apache.pulsar/pulsar","source":"GHSA-3mg9-m3f6-v7fq"}],"prev":{"headline":"Prototype Pollution","id":"CVE-2022-24279"},"products":["Apache Pulsar"],"published":"2022-09-23","related":[{"cvss_score":9.8,"headline":"Authentication with JWT allows use of “none”-algorithm","id":"CVE-2021-22160","kev_date_added":null,"published":"2021-05-26"},{"cvss_score":9.6,"headline":"Apache Pulsar: Incorrect Authorization for Function Worker when using mTLS Authentication through Pulsar Proxy","id":"CVE-2023-30429","kev_date_added":null,"published":"2023-07-12"},{"cvss_score":8.5,"headline":"Apache Pulsar: Improper Input Validation in Pulsar Function Worker allows Remote Code Execution","id":"CVE-2024-27135","kev_date_added":null,"published":"2024-03-12"},{"cvss_score":8.5,"headline":"Apache Pulsar: Pulsar Functions Worker Allows Unauthorized File Access and Unauthorized HTTP/HTTPS Proxying","id":"CVE-2024-27894","kev_date_added":null,"published":"2024-03-12"},{"cvss_score":8.4,"headline":"Apache Pulsar: Pulsar Functions Worker's Archive Extraction Vulnerability Allows Unauthorized File Modification","id":"CVE-2024-27317","kev_date_added":null,"published":"2024-03-12"},{"cvss_score":8.2,"headline":"Apache Pulsar: Improper Authentication for Pulsar Proxy Statistics Endpoint","id":"CVE-2022-34321","kev_date_added":null,"published":"2024-03-12"},{"cvss_score":8.2,"headline":"Apache Pulsar Broker: Incorrect Authorization Validation for Rest Producer","id":"CVE-2023-30428","kev_date_added":null,"published":"2023-07-12"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-05-22","vendors":["Apache Software Foundation"]},"summary":"An attacker with a valid token can force the Pulsar Proxy to initiate TCP connections to arbitrary addresses, enabling Denial of Service attacks.","url":"https://insights.sbomify.com/CVE-2022-24280/"}