# CVE-2022-24280: Apache Pulsar Proxy target broker address isn't validated

> An attacker with a valid token can force the Pulsar Proxy to initiate TCP connections to arbitrary addresses, enabling Denial of Service attacks.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 23 Sep 2022
- **Updated:** 22 May 2025
- **Also known as:** GHSA-3mg9-m3f6-v7fq

## What is CVE-2022-24280?

CVE-2022-24280 is a medium-severity server-side request forgery vulnerability in Apache Pulsar, published on 23 Sep 2022. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Improper Input Validation vulnerability in Proxy component of Apache Pulsar allows an attacker to make TCP/IP connection attempts that originate from the Pulsar Proxy's IP address. When the Apache Pulsar Proxy component is used, it is possible to attempt to open TCP/IP connections to any IP address and port that the Pulsar Proxy can connect to. An attacker could use this as a way for DoS attacks that originate from the Pulsar Proxy's IP address. It hasn’t been detected that the Pulsar Proxy authentication can be bypassed. The attacker will have to have a valid token to a properly secured Pulsar Proxy. This issue affects Apache Pulsar Proxy versions 2.7.0 to 2.7.4; 2.8.0 to 2.8.2; 2.9.0 to 2.9.1; 2.6.4 and earlier.

Weakness: CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2022-24280?

6 open source packages ship an affected version, including org.apache.pulsar:pulsar. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.pulsar:pulsar` | Maven | All versions | 2.7.5 |
| `org.apache.pulsar:pulsar` | Maven | All versions | 2.7.5 |
| `org.apache.pulsar:pulsar` | Maven | From 2.8.0 | 2.8.3 |
| `org.apache.pulsar:pulsar` | Maven | From 2.8.0 | 2.8.3 |
| `org.apache.pulsar:pulsar` | Maven | From 2.9.0 | 2.9.2 |
| `org.apache.pulsar:pulsar` | Maven | From 2.9.0 | 2.9.2 |

Products: Apache Pulsar.

## How do I fix CVE-2022-24280?

Upgrade org.apache.pulsar:pulsar to a fixed version for your release line: 2.7.5, 2.8.3 or 2.9.2.

## Is CVE-2022-24280 being exploited?

There is no known exploitation of CVE-2022-24280 in the wild and no public exploit code.

## Other vulnerabilities in Apache Pulsar

- [CVE-2021-22160](https://insights.sbomify.com/CVE-2021-22160/): Authentication with JWT allows use of “none”-algorithm (critical 9.8)
- [CVE-2023-30429](https://insights.sbomify.com/CVE-2023-30429/): Apache Pulsar: Incorrect Authorization for Function Worker when using mTLS Authentication through Pulsar Proxy (critical 9.6)
- [CVE-2024-27135](https://insights.sbomify.com/CVE-2024-27135/): Apache Pulsar: Improper Input Validation in Pulsar Function Worker allows Remote Code Execution (high 8.5)
- [CVE-2024-27894](https://insights.sbomify.com/CVE-2024-27894/): Apache Pulsar: Pulsar Functions Worker Allows Unauthorized File Access and Unauthorized HTTP/HTTPS Proxying (high 8.5)
- [CVE-2024-27317](https://insights.sbomify.com/CVE-2024-27317/): Apache Pulsar: Pulsar Functions Worker's Archive Extraction Vulnerability Allows Unauthorized File Modification (high 8.4)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-24280 and fix it if it is affected.

What it is: CVE-2022-24280 is a medium-severity server-side request forgery vulnerability in Apache Pulsar, published on 23 Sep 2022. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-24280 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.pulsar:pulsar (Maven): affected all versions; fixed in 2.7.5
- org.apache.pulsar:pulsar (Maven): affected all versions; fixed in 2.7.5
- org.apache.pulsar:pulsar (Maven): affected from 2.8.0; fixed in 2.8.3
- org.apache.pulsar:pulsar (Maven): affected from 2.8.0; fixed in 2.8.3
- org.apache.pulsar:pulsar (Maven): affected from 2.9.0; fixed in 2.9.2
- org.apache.pulsar:pulsar (Maven): affected from 2.9.0; fixed in 2.9.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-24280/ (Markdown: https://insights.sbomify.com/CVE-2022-24280/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-24280
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-24280
- OSV: https://osv.dev/vulnerability/CVE-2022-24280

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-24280/
Summaries are generated and may contain mistakes; the official description above is the record.
