# CVE-2022-24288: Apache Airflow: RCE in example DAGs

> Attackers can execute arbitrary OS commands via unsanitized parameters in example DAGs within the Apache Airflow web UI.

- **Severity:** High 8.8 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 25 Feb 2022
- **Updated:** 3 Aug 2024
- **Also known as:** BIT-airflow-2022-24288, GHSA-3v7g-4pg3-7r6j, PYSEC-2022-30

## What is CVE-2022-24288?

CVE-2022-24288 is a high-severity command injection vulnerability in Apache Airflow, published on 25 Feb 2022. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

In Apache Airflow, prior to version 2.2.4, some example DAGs did not properly sanitize user-provided params, making them susceptible to OS Command Injection from the web UI.

Weakness: CWE-78 (Improper Neutralization of Special Elements used in an OS Command)

## Which versions are affected by CVE-2022-24288?

4 open source packages ship an affected version, including apache-airflow and airflow. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `apache-airflow` | PyPI | All versions | 2.2.4 |
| `apache-airflow` | PyPI | All versions | 2.2.4 |
| `apache-airflow` | PyPI | All versions | 2.2.4 |
| `airflow` | Bitnami | All versions | 2.2.4 |

Products: Apache Airflow.

## How do I fix CVE-2022-24288?

Upgrade apache-airflow to 2.2.4 or later.

## Is CVE-2022-24288 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-24288 exists.

Public exploit code:

- Apache Airflow OS Command Injection (nuclei): http/cves/2022/CVE-2022-24288.yaml

## Other vulnerabilities in Apache Airflow

- [CVE-2020-13927](https://insights.sbomify.com/CVE-2020-13927/): Apache Airflow's Experimental API Authentication Bypass (critical 9.8, exploited in the wild)
- [CVE-2020-11978](https://insights.sbomify.com/CVE-2020-11978/): Apache Airflow Command Injection (high 8.8, exploited in the wild)
- [CVE-2026-33264](https://insights.sbomify.com/CVE-2026-33264/): Apache Airflow: DAG author RCE on webserver via unrestricted import_string() in BaseSerialization.deserialize() (critical 9.8)
- [CVE-2023-25754](https://insights.sbomify.com/CVE-2023-25754/): Apache Airflow: Privilege escalation using airflow logs (critical 9.8)
- [CVE-2023-22884](https://insights.sbomify.com/CVE-2023-22884/): Apache Airflow, Apache Airflow MySQL Provider: Arbitrary file read via MySQL provider in Apache Airflow (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-24288 and fix it if it is affected.

What it is: CVE-2022-24288 is a high-severity command injection vulnerability in Apache Airflow, published on 25 Feb 2022. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-24288 exists.

Affected packages and fixed versions:
- apache-airflow (PyPI): affected all versions; fixed in 2.2.4
- apache-airflow (PyPI): affected all versions; fixed in 2.2.4
- apache-airflow (PyPI): affected all versions; fixed in 2.2.4
- airflow (Bitnami): affected all versions; fixed in 2.2.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-24288/ (Markdown: https://insights.sbomify.com/CVE-2022-24288/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-24288
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-24288
- OSV: https://osv.dev/vulnerability/CVE-2022-24288

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-24288/
Summaries are generated and may contain mistakes; the official description above is the record.
