{"answers":{"affected":"2 open source packages ship an affected version, including org.apache.cayenne:cayenne-server. It affects 1 product.","exploited":"There is no known exploitation of CVE-2022-24289 in the wild and no public exploit code.","fix":"Upgrade org.apache.cayenne:cayenne-server to 4.1.1 or later.","what":"CVE-2022-24289 is a high-severity unsafe deserialization vulnerability in Apache Cayenne, published on 11 Feb 2022. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2022-24289 and fix it if it is affected.\n\nWhat it is: CVE-2022-24289 is a high-severity unsafe deserialization vulnerability in Apache Cayenne, published on 11 Feb 2022. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2022-24289 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.apache.cayenne:cayenne-server (Maven): affected all versions; fixed in 4.1.1\n- org.apache.cayenne:cayenne-server (Maven): affected all versions; fixed in 4.1.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-24289/ (Markdown: https://insights.sbomify.com/CVE-2022-24289/index.md)","id":"CVE-2022-24289","markdown":"https://insights.sbomify.com/CVE-2022-24289/index.md","name":"CVE-2022-24289","record":{"aliases":["GHSA-c58c-w527-h77p"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":true,"product_category":"Java ORM library","requires_auth":"low_privilege","summary":"An attacker with client access to the optional Remote Object Persistence feature can achieve arbitrary code execution via malicious Hessian payloads.","user_interaction":"not_required","vuln_class":"deserialization"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"apache","cpe":[{"product":"cayenne","vendor":"apache"}],"cvss":{"score":8.8,"severity":"high","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-502","name":"Deserialization of Untrusted Data"}],"description":"Hessian serialization is a network protocol that supports object-based transmission. Apache Cayenne's optional Remote Object Persistence (ROP) feature is a web services-based technology that provides object persistence and query functionality to 'remote' applications. In Apache Cayenne 4.1 and earlier, running on non-current patch versions of Java, an attacker with client access to Cayenne ROP can transmit a malicious payload to any vulnerable third-party dependency on the server. This can result in arbitrary code execution.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Deserialization of untrusted data in the Hessian Component of Apache Cayenne 4.1 with older Java versions","id":"CVE-2022-24289","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"deserialization","year":"2022"},"n_packages":2,"n_references":2,"next":{"headline":"Memory corruption in Teamcenter V12.4","id":"CVE-2022-24290"},"packages":[{"ecosystem":"Maven","fixed":["4.1.1"],"introduced":["0"],"last_affected":[],"package":"org.apache.cayenne:cayenne-server","purl":null,"source":"GHSA-c58c-w527-h77p"},{"ecosystem":"Maven","fixed":["4.1.1"],"introduced":["0"],"last_affected":[],"package":"org.apache.cayenne:cayenne-server","purl":"pkg:maven/org.apache.cayenne/cayenne-server","source":"GHSA-c58c-w527-h77p"}],"prev":{"headline":"Apache Airflow: RCE in example DAGs","id":"CVE-2022-24288"},"products":["Apache Cayenne"],"published":"2022-02-11","related":[{"cvss_score":8.1,"headline":"XML External Entity Reference in Apache Cayenne","id":"CVE-2018-11758","kev_date_added":null,"published":"2018-08-22"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-03","vendors":["Apache Software Foundation"]},"summary":"An attacker with client access to the optional Remote Object Persistence feature can achieve arbitrary code execution via malicious Hessian payloads.","url":"https://insights.sbomify.com/CVE-2022-24289/"}