# CVE-2022-24294: ReDoS in Apache MXNet RTC Module

> Attackers can cause denial of service in Apache MXNet by loading models with specially crafted operator names that trigger excessive resource consumption in regular expressions.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 24 Jul 2022
- **Updated:** 3 Aug 2024
- **Also known as:** BIT-mxnet-2022-24294, GHSA-xxj3-55p6-xg3h, PYSEC-2026-850

## What is CVE-2022-24294?

CVE-2022-24294 is a high-severity denial of service vulnerability in Apache MXNet, published on 24 Jul 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

A regular expression used in Apache MXNet (incubating) is vulnerable to a potential denial-of-service by excessive resource consumption. The bug could be exploited when loading a model in Apache MXNet that has a specially crafted operator name that would cause the regular expression evaluation to use excessive resources to attempt a match. This issue affects Apache MXNet versions prior to 1.9.1.

Weakness: CWE-400 (Uncontrolled Resource Consumption)

## Which versions are affected by CVE-2022-24294?

4 open source packages ship an affected version, including mxnet. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `mxnet` | Bitnami | All versions | 1.9.1 |
| `mxnet` | PyPI | All versions | 1.9.1 |
| `mxnet` | PyPI | All versions | 1.9.1 |
| `mxnet` | PyPI | All versions | 1.9.1 |

Products: Apache Mxnet.

## How do I fix CVE-2022-24294?

Upgrade mxnet to 1.9.1 or later.

## Is CVE-2022-24294 being exploited?

There is no known exploitation of CVE-2022-24294 in the wild and no public exploit code.

## Other vulnerabilities in Apache MXNet

- [CVE-2018-1281](https://insights.sbomify.com/CVE-2018-1281/): Misconfiguration in Apache MXNet (medium 6.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-24294 and fix it if it is affected.

What it is: CVE-2022-24294 is a high-severity denial of service vulnerability in Apache MXNet, published on 24 Jul 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-24294 in the wild and no public exploit code.

Affected packages and fixed versions:
- mxnet (Bitnami): affected all versions; fixed in 1.9.1
- mxnet (PyPI): affected all versions; fixed in 1.9.1
- mxnet (PyPI): affected all versions; fixed in 1.9.1
- mxnet (PyPI): affected all versions; fixed in 1.9.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-24294/ (Markdown: https://insights.sbomify.com/CVE-2022-24294/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-24294
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-24294
- OSV: https://osv.dev/vulnerability/CVE-2022-24294

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-24294/
Summaries are generated and may contain mistakes; the official description above is the record.
