# CVE-2022-24302: Race Condition in Paramiko

> A race condition in Paramiko's private key writing allows attackers to read sensitive key data before permissions are set.

- **Severity:** Medium 5.9 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 17 Mar 2022
- **Updated:** 16 Dec 2025
- **Also known as:** DEBIAN-CVE-2022-24302, DLA-2959-1, DLA-3104-1, DLA-4409-1, GHSA-f8q4-jwww-x3wv, MGASA-2022-0132, OESA-2022-1609, PYSEC-2022-166, RHSA-2022:4712, RHSA-2022:8845, RHSA-2022:8863, SUSE-SU-2022:1446-1, SUSE-SU-2022:1447-1, UBUNTU-CVE-2022-24302, USN-5351-1, USN-5351-2, openSUSE-SU-2024:13300-1

## What is CVE-2022-24302?

CVE-2022-24302 is a medium-severity vulnerability in Debian Debian Linux, published on 17 Mar 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

In Paramiko before 2.10.1, a race condition (between creation and chmod) in the write_private_key_file function could allow unauthorized information disclosure.

Weakness: CWE-362 (Concurrent Execution using Shared Resource with Improper Synchronization)

## Which versions are affected by CVE-2022-24302?

5 open source packages ship an affected version, including paramiko. It affects 3 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `paramiko` | PyPI | All versions | 2.9.3, 2.10.1 |
| `paramiko` | PyPI | From 2.10.0 | 2.10.1 |
| `paramiko` | PyPI | From 2.10.0 | 2.10.1 |
| `paramiko` | PyPI | From 2.9.0 | 2.9.3 |
| `paramiko` | PyPI | From 2.9.0 | 2.9.3 |
| `python-paramiko` | Red Hat:openstack:16.1::el8 | All versions | 0:2.4.2-8.el8ost |
| `python3-paramiko` | Red Hat:openstack:16.1::el8 | All versions | 0:2.4.2-8.el8ost |
| `python-paramiko` | Red Hat:openstack:16.2::el8 | All versions | 0:2.4.2-8.el8ost |
| `python3-paramiko` | Red Hat:openstack:16.2::el8 | All versions | 0:2.4.2-8.el8ost |
| `python-paramiko` | Red Hat:rhev_hypervisor:4.4::el8 | All versions | 0:2.4.3-3.el8ev |
| `python-paramiko-doc` | Red Hat:rhev_hypervisor:4.4::el8 | All versions | 0:2.4.3-3.el8ev |
| `python3-paramiko` | Red Hat:rhev_hypervisor:4.4::el8 | All versions | 0:2.4.3-3.el8ev |
| `python-paramiko` | Red Hat:rhev_manager:4.4:el8 | All versions | 0:2.4.3-3.el8ev |
| `python-paramiko-doc` | Red Hat:rhev_manager:4.4:el8 | All versions | 0:2.4.3-3.el8ev |
| `python3-paramiko` | Red Hat:rhev_manager:4.4:el8 | All versions | 0:2.4.3-3.el8ev |
| `python-paramiko` | SUSE:Linux Enterprise Module for Basesystem 15 SP3 | All versions | 2.4.2-150100.6.12.1 |
| `python-paramiko` | SUSE:Linux Enterprise Module for Public Cloud 12 | All versions | 2.4.0-9.13.1 |
| `python-paramiko` | SUSE:Linux Enterprise Module for Python 2 15 SP3 | All versions | 2.4.2-150100.6.12.1 |
| `python-paramiko` | SUSE:Linux Enterprise Real Time 15 SP2 | All versions | 2.4.2-150100.6.12.1 |
| `python-paramiko` | openSUSE:Leap 15.3 | All versions | 2.4.2-150100.6.12.1 |
| `python-paramiko` | openSUSE:Leap 15.4 | All versions | 2.4.2-150100.6.12.1 |
| `python-paramiko` | openSUSE:Tumbleweed | All versions | 3.3.1-2.1 |

Products: Debian Debian Linux, Fedoraproject Fedora, Paramiko Paramiko.

## How do I fix CVE-2022-24302?

Upgrade paramiko to a fixed version for your release line: 2.9.3 or 2.10.1.

## Is CVE-2022-24302 being exploited?

There is no known exploitation of CVE-2022-24302 in the wild and no public exploit code.

## Other vulnerabilities in Debian Debian Linux

- [CVE-2015-3306](https://insights.sbomify.com/CVE-2015-3306/): ProFTPD Improper Access Control (critical 10.0, exploited in the wild)
- [CVE-2025-49113](https://insights.sbomify.com/CVE-2025-49113/): RoundCube Webmail Deserialization of Untrusted Data (critical 9.9, exploited in the wild)
- [CVE-2026-24061](https://insights.sbomify.com/CVE-2026-24061/): GNU InetUtils Argument Injection (critical 9.8, exploited in the wild)
- [CVE-2025-39682](https://insights.sbomify.com/CVE-2025-39682/): Linux Kernel Improper Check for Unusual or Exceptional Conditions (critical 9.8, exploited in the wild)
- [CVE-2024-9680](https://insights.sbomify.com/CVE-2024-9680/): Mozilla Firefox Use-After-Free (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-24302 and fix it if it is affected.

What it is: CVE-2022-24302 is a medium-severity vulnerability in Debian Debian Linux, published on 17 Mar 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-24302 in the wild and no public exploit code.

Affected packages and fixed versions:
- paramiko (PyPI): affected all versions; fixed in 2.9.3, 2.10.1
- paramiko (PyPI): affected from 2.10.0; fixed in 2.10.1
- paramiko (PyPI): affected from 2.10.0; fixed in 2.10.1
- paramiko (PyPI): affected from 2.9.0; fixed in 2.9.3
- paramiko (PyPI): affected from 2.9.0; fixed in 2.9.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-24302/ (Markdown: https://insights.sbomify.com/CVE-2022-24302/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-24302
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-24302
- OSV: https://osv.dev/vulnerability/CVE-2022-24302

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-24302/
Summaries are generated and may contain mistakes; the official description above is the record.
