# CVE-2022-24375: Denial of Service (DoS)

> Attackers can cause denial of service in node-opcua by sending multiple CloseSession requests with deleteSubscription set to false, exhausting memory.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H/E:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 24 Aug 2022
- **Updated:** 16 Sep 2024
- **Also known as:** GHSA-vh4f-fgpp-x8x2

## What is CVE-2022-24375?

CVE-2022-24375 is a high-severity denial of service vulnerability in node-opcua, published on 24 Aug 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The package node-opcua before 2.74.0 are vulnerable to Denial of Service (DoS) when bypassing the limitations for excessive memory consumption by sending multiple CloseSession requests with the deleteSubscription parameter equal to False.

Weakness: CWE-400 (Uncontrolled Resource Consumption)

## Which versions are affected by CVE-2022-24375?

2 open source packages ship an affected version, including node-opcua. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `node-opcua` | npm | All versions | 2.74.0 |
| `node-opcua` | npm | All versions | 2.74.0 |

Products: Node-Opcua Project Node-Opcua.

## How do I fix CVE-2022-24375?

Upgrade node-opcua to 2.74.0 or later.

## Is CVE-2022-24375 being exploited?

There is no known exploitation of CVE-2022-24375 in the wild and no public exploit code.

## Other vulnerabilities in node-opcua

- [CVE-2022-21208](https://insights.sbomify.com/CVE-2022-21208/): Denial of Service (DoS) (high 7.5)
- [CVE-2022-25231](https://insights.sbomify.com/CVE-2022-25231/): Denial of Service (DoS) (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-24375 and fix it if it is affected.

What it is: CVE-2022-24375 is a high-severity denial of service vulnerability in node-opcua, published on 24 Aug 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-24375 in the wild and no public exploit code.

Affected packages and fixed versions:
- node-opcua (npm): affected all versions; fixed in 2.74.0
- node-opcua (npm): affected all versions; fixed in 2.74.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-24375/ (Markdown: https://insights.sbomify.com/CVE-2022-24375/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-24375
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-24375
- OSV: https://osv.dev/vulnerability/CVE-2022-24375

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-24375/
Summaries are generated and may contain mistakes; the official description above is the record.
