# CVE-2022-24377: Command Injection

> Attackers can execute arbitrary commands via improper input sanitization in the cycle-import-check npm package.

- **Severity:** High 7.4 (`CVSS:3.1/AV:L/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H/E:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 15 Dec 2022
- **Updated:** 17 Apr 2025
- **Also known as:** GHSA-995x-33wq-8gc9

## What is CVE-2022-24377?

CVE-2022-24377 is a high-severity command injection vulnerability in cycle-import-check, published on 15 Dec 2022. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

The package cycle-import-check before 1.3.2 are vulnerable to Command Injection via the writeFileToTmpDirAndOpenIt function due to improper user-input sanitization.

Weakness: CWE-78 (Improper Neutralization of Special Elements used in an OS Command)

## Which versions are affected by CVE-2022-24377?

2 open source packages ship an affected version, including cycle-import-check. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `cycle-import-check` | npm | All versions | 1.3.2 |
| `cycle-import-check` | npm | All versions | 1.3.2 |

Products: Cycle-Import-Check Project Cycle-Import-Check.

## How do I fix CVE-2022-24377?

Upgrade cycle-import-check to 1.3.2 or later.

## Is CVE-2022-24377 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-24377 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-24377 and fix it if it is affected.

What it is: CVE-2022-24377 is a high-severity command injection vulnerability in cycle-import-check, published on 15 Dec 2022. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-24377 exists.

Affected packages and fixed versions:
- cycle-import-check (npm): affected all versions; fixed in 1.3.2
- cycle-import-check (npm): affected all versions; fixed in 1.3.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-24377/ (Markdown: https://insights.sbomify.com/CVE-2022-24377/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-24377
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-24377
- OSV: https://osv.dev/vulnerability/CVE-2022-24377

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-24377/
Summaries are generated and may contain mistakes; the official description above is the record.
