# CVE-2022-24429: Arbitrary Code Injection

> Attackers can inject arbitrary code via crafted SVG files to execute code and read sensitive files from the system.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N/E:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 10 Jun 2022
- **Updated:** 17 Sep 2024
- **Also known as:** GHSA-54px-mhwv-5v8x, SNYK-JS-CONVERTSVGCORE-2859212

## What is CVE-2022-24429?

CVE-2022-24429 is a high-severity code injection vulnerability in convert-svg-core, published on 10 Jun 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The package convert-svg-core before 0.6.3 are vulnerable to Arbitrary Code Injection when using a specially crafted SVG file. An attacker can read arbitrary files from the file system and then show the file content as a converted PNG file.

Weakness: CWE-94 (Improper Control of Generation of Code)

## Which versions are affected by CVE-2022-24429?

2 open source packages ship an affected version, including convert-svg-core. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `convert-svg-core` | npm | All versions | 0.6.3 |
| `convert-svg-core` | npm | All versions | 0.6.3 |

Products: Convert-Svg-Core Project Convert-Svg-Core.

## How do I fix CVE-2022-24429?

Upgrade convert-svg-core to 0.6.3 or later.

## Is CVE-2022-24429 being exploited?

There is no known exploitation of CVE-2022-24429 in the wild and no public exploit code.

## Other vulnerabilities in convert-svg-core

- [CVE-2022-25759](https://insights.sbomify.com/CVE-2022-25759/): Remote Code Injection (critical 9.9)
- [CVE-2021-23631](https://insights.sbomify.com/CVE-2021-23631/): Directory Traversal (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-24429 and fix it if it is affected.

What it is: CVE-2022-24429 is a high-severity code injection vulnerability in convert-svg-core, published on 10 Jun 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-24429 in the wild and no public exploit code.

Affected packages and fixed versions:
- convert-svg-core (npm): affected all versions; fixed in 0.6.3
- convert-svg-core (npm): affected all versions; fixed in 0.6.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-24429/ (Markdown: https://insights.sbomify.com/CVE-2022-24429/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-24429
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-24429
- OSV: https://osv.dev/vulnerability/CVE-2022-24429

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-24429/
Summaries are generated and may contain mistakes; the official description above is the record.
