{"answers":{"affected":"2 open source packages ship an affected version, including simple-git. It affects 1 product.","exploited":"There is no known exploitation of CVE-2022-24433 in the wild and no public exploit code.","fix":"Upgrade simple-git to 3.3.0 or later.","what":"CVE-2022-24433 is a high-severity command injection vulnerability in simple-git, published on 11 Mar 2022. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2022-24433 and fix it if it is affected.\n\nWhat it is: CVE-2022-24433 is a high-severity command injection vulnerability in simple-git, published on 11 Mar 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2022-24433 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- simple-git (npm): affected all versions; fixed in 3.3.0\n- simple-git (npm): affected all versions; fixed in 3.3.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-24433/ (Markdown: https://insights.sbomify.com/CVE-2022-24433/index.md)","id":"CVE-2022-24433","markdown":"https://insights.sbomify.com/CVE-2022-24433/index.md","name":"CVE-2022-24433","record":{"aliases":["GHSA-3f95-r44v-8mrg"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Node.js git library","requires_auth":"none","summary":"Attackers can execute arbitrary commands via argument injection in the fetch function of the simple-git library.","user_interaction":"not_required","vuln_class":"command_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"snyk","cpe":[{"product":"simple-git","vendor":"simple-git_project"}],"cvss":{"score":8.1,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-88","name":"Improper Neutralization of Argument Delimiters in a Command"}],"description":"The package simple-git before 3.3.0 are vulnerable to Command Injection via argument injection. When calling the .fetch(remote, branch, handlerFn) function, both the remote and branch parameters are passed to the git fetch subcommand. By injecting some git options it was possible to get arbitrary command execution.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Command Injection","id":"CVE-2022-24433","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"command_injection","year":"2022"},"n_packages":2,"n_references":4,"next":{"headline":"Denial of Service (DoS)","id":"CVE-2022-24434"},"packages":[{"ecosystem":"npm","fixed":["3.3.0"],"introduced":["0"],"last_affected":[],"package":"simple-git","purl":null,"source":"GHSA-3f95-r44v-8mrg"},{"ecosystem":"npm","fixed":["3.3.0"],"introduced":["0"],"last_affected":[],"package":"simple-git","purl":"pkg:npm/simple-git","source":"GHSA-3f95-r44v-8mrg"}],"prev":{"headline":"ICSA-22-062-01 IPCOMM ipDIO","id":"CVE-2022-24432"},"products":["simple-git"],"published":"2022-03-11","related":[{"cvss_score":9.8,"headline":"simple-git has blockUnsafeOperationsPlugin bypass via case-insensitive protocol.allow config key that enables RCE","id":"CVE-2026-28292","kev_date_added":null,"published":"2026-03-10"},{"cvss_score":9.2,"headline":"simple-git unsafe-operation guard does not block trailer command configuration","id":"CVE-2026-102828","kev_date_added":null,"published":"2026-09-29"},{"cvss_score":9.2,"headline":"simple-git is vulnerable to Remote Code Execution","id":"CVE-2026-6951","kev_date_added":null,"published":"2026-04-25"},{"cvss_score":8.1,"headline":"simple-git allows command execution through unblocked Git configuration includes","id":"CVE-2026-102826","kev_date_added":null,"published":"2026-09-29"},{"cvss_score":8.1,"headline":"simple-git: unsafe-operations plugin bypass via git long-option abbreviation (--receive-p/--exe) -\u003e command execution (residual of CVE-2026-28291)","id":"CVE-2026-102827","kev_date_added":null,"published":"2026-09-29"},{"cvss_score":8.1,"headline":"simple-git has Command Execution via Option-Parsing Bypass","id":"CVE-2026-28291","kev_date_added":null,"published":"2026-04-13"},{"cvss_score":8.1,"headline":"Remote code execution in simple-git","id":"CVE-2022-25860","kev_date_added":null,"published":"2023-01-24"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-09-16","vendors":["n/a"]},"summary":"Attackers can execute arbitrary commands via argument injection in the fetch function of the simple-git library.","url":"https://insights.sbomify.com/CVE-2022-24433/"}