{"answers":{"affected":"2 open source packages ship an affected version, including git-pull-or-clone. It affects 1 product.","exploited":"There is no known exploitation of CVE-2022-24437 in the wild and no public exploit code.","fix":"Upgrade git-pull-or-clone to 2.0.2 or later.","what":"CVE-2022-24437 is a critical command injection vulnerability in git-pull-or-clone, published on 1 May 2022. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2022-24437 and fix it if it is affected.\n\nWhat it is: CVE-2022-24437 is a critical command injection vulnerability in git-pull-or-clone, published on 1 May 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2022-24437 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- git-pull-or-clone (npm): affected all versions; fixed in 2.0.2\n- git-pull-or-clone (npm): affected all versions; fixed in 2.0.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-24437/ (Markdown: https://insights.sbomify.com/CVE-2022-24437/index.md)","id":"CVE-2022-24437","markdown":"https://insights.sbomify.com/CVE-2022-24437/index.md","name":"CVE-2022-24437","record":{"aliases":["GHSA-3x62-x456-q2vm","SNYK-JS-GITPULLORCLONE-2434307"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Node.js git library","requires_auth":"none","summary":"Attackers can execute arbitrary commands via the outpath parameter in the git-pull-or-clone Node.js library.","user_interaction":"not_required","vuln_class":"command_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"snyk","cpe":[{"product":"git-pull-or-clone","vendor":"git-pull-or-clone_project"}],"cvss":{"score":9.8,"severity":"critical","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-88","name":"Improper Neutralization of Argument Delimiters in a Command"}],"description":"The package git-pull-or-clone before 2.0.2 are vulnerable to Command Injection due to the use of the --upload-pack feature of git which is also supported for git clone. The source includes the use of the secure child process API spawn(). However, the outpath parameter passed to it may be a command-line argument to the git clone command and result in arbitrary command injection.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Command Injection","id":"CVE-2022-24437","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"command_injection","year":"2022"},"n_packages":2,"n_references":3,"next":{"headline":"Remote Code Execution (RCE)","id":"CVE-2022-24439"},"packages":[{"ecosystem":"npm","fixed":["2.0.2"],"introduced":["0"],"last_affected":[],"package":"git-pull-or-clone","purl":null,"source":"GHSA-3x62-x456-q2vm"},{"ecosystem":"npm","fixed":["2.0.2"],"introduced":["0"],"last_affected":[],"package":"git-pull-or-clone","purl":"pkg:npm/git-pull-or-clone","source":"GHSA-3x62-x456-q2vm"}],"prev":{"headline":"Information disclosure in Intel(R) Processors","id":"CVE-2022-24436"},"products":["git-pull-or-clone"],"published":"2022-05-01","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-09-16","vendors":["n/a"]},"summary":"Attackers can execute arbitrary commands via the outpath parameter in the git-pull-or-clone Node.js library.","url":"https://insights.sbomify.com/CVE-2022-24437/"}