# CVE-2022-24437: Command Injection

> Attackers can execute arbitrary commands via the outpath parameter in the git-pull-or-clone Node.js library.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 1 May 2022
- **Updated:** 16 Sep 2024
- **Also known as:** GHSA-3x62-x456-q2vm, SNYK-JS-GITPULLORCLONE-2434307

## What is CVE-2022-24437?

CVE-2022-24437 is a critical command injection vulnerability in git-pull-or-clone, published on 1 May 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The package git-pull-or-clone before 2.0.2 are vulnerable to Command Injection due to the use of the --upload-pack feature of git which is also supported for git clone. The source includes the use of the secure child process API spawn(). However, the outpath parameter passed to it may be a command-line argument to the git clone command and result in arbitrary command injection.

Weakness: CWE-88 (Improper Neutralization of Argument Delimiters in a Command)

## Which versions are affected by CVE-2022-24437?

2 open source packages ship an affected version, including git-pull-or-clone. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `git-pull-or-clone` | npm | All versions | 2.0.2 |
| `git-pull-or-clone` | npm | All versions | 2.0.2 |

Products: Git-Pull-or-Clone Project Git-Pull-or-Clone.

## How do I fix CVE-2022-24437?

Upgrade git-pull-or-clone to 2.0.2 or later.

## Is CVE-2022-24437 being exploited?

There is no known exploitation of CVE-2022-24437 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-24437 and fix it if it is affected.

What it is: CVE-2022-24437 is a critical command injection vulnerability in git-pull-or-clone, published on 1 May 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-24437 in the wild and no public exploit code.

Affected packages and fixed versions:
- git-pull-or-clone (npm): affected all versions; fixed in 2.0.2
- git-pull-or-clone (npm): affected all versions; fixed in 2.0.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-24437/ (Markdown: https://insights.sbomify.com/CVE-2022-24437/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-24437
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-24437
- OSV: https://osv.dev/vulnerability/CVE-2022-24437

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-24437/
Summaries are generated and may contain mistakes; the official description above is the record.
