# CVE-2022-24439: Remote Code Execution (RCE)

> Attackers can execute arbitrary code by injecting malicious URLs into GitPython clone commands due to insufficient input sanitization.

- **Severity:** High 8.1 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 12 Dec 2022
- **Updated:** 3 Nov 2025
- **Also known as:** DEBIAN-CVE-2022-24439, GHSA-hcpj-qp55-gfph, MGASA-2023-0001, PYSEC-2022-42992, UBUNTU-CVE-2022-24439, USN-5968-1, openSUSE-SU-2024:12596-1, openSUSE-SU-2024:13510-1, openSUSE-SU-2025:14858-1

## What is CVE-2022-24439?

CVE-2022-24439 is a high-severity command injection vulnerability in Debian Debian Linux, published on 12 Dec 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

All versions of package gitpython are vulnerable to Remote Code Execution (RCE) due to improper user input validation, which makes it possible to inject a maliciously crafted remote URL into the clone command. Exploiting this vulnerability is possible because the library makes external calls to git without sufficient sanitization of input arguments.

Weakness: CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2022-24439?

3 open source packages ship an affected version, including gitpython and GitPython. It affects 3 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `gitpython` | PyPI | All versions | 3.1.30 |
| `gitpython` | PyPI | All versions | 3.1.30 |
| `GitPython` | PyPI | All versions | 3.1.30 |
| `python-GitPython` | openSUSE:Tumbleweed | All versions | 3.1.44-1.1 |
| `python3-bandit` | openSUSE:Tumbleweed | All versions | 1.7.6-1.1 |

Products: Debian Debian Linux, Fedoraproject Fedora, Gitpython Project Gitpython.

## How do I fix CVE-2022-24439?

Upgrade gitpython to 3.1.30 or later.

## Is CVE-2022-24439 being exploited?

There is no known exploitation of CVE-2022-24439 in the wild and no public exploit code.

Public exploit code:

- Method I used for my Practical Pentest Module. (github_poc): https://github.com/Makkkiiii/GitPython-Exploit-CVE-2022-24439
- https://github.com/muhammadhendro/CVE-2022-24439 (github_poc): https://github.com/muhammadhendro/CVE-2022-24439

## Other vulnerabilities in Debian Debian Linux

- [CVE-2015-3306](https://insights.sbomify.com/CVE-2015-3306/): ProFTPD Improper Access Control (critical 10.0, exploited in the wild)
- [CVE-2025-49113](https://insights.sbomify.com/CVE-2025-49113/): RoundCube Webmail Deserialization of Untrusted Data (critical 9.9, exploited in the wild)
- [CVE-2026-24061](https://insights.sbomify.com/CVE-2026-24061/): GNU InetUtils Argument Injection (critical 9.8, exploited in the wild)
- [CVE-2025-39682](https://insights.sbomify.com/CVE-2025-39682/): Linux Kernel Improper Check for Unusual or Exceptional Conditions (critical 9.8, exploited in the wild)
- [CVE-2024-9680](https://insights.sbomify.com/CVE-2024-9680/): Mozilla Firefox Use-After-Free (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-24439 and fix it if it is affected.

What it is: CVE-2022-24439 is a high-severity command injection vulnerability in Debian Debian Linux, published on 12 Dec 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-24439 in the wild and no public exploit code.

Affected packages and fixed versions:
- gitpython (PyPI): affected all versions; fixed in 3.1.30
- gitpython (PyPI): affected all versions; fixed in 3.1.30
- GitPython (PyPI): affected all versions; fixed in 3.1.30

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-24439/ (Markdown: https://insights.sbomify.com/CVE-2022-24439/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-24439
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-24439
- OSV: https://osv.dev/vulnerability/CVE-2022-24439

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-24439/
Summaries are generated and may contain mistakes; the official description above is the record.
