CVE-2022-24440 Command Injection
Attackers can execute arbitrary commands via git argument injection in the CocoaPods downloader library when processing malicious git or branch parameters.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2022-24440?
CVE-2022-24440 is a high-severity command injection vulnerability in cocoapods-downloader, published on 1 Apr 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
The package cocoapods-downloader before 1.6.0, from 1.6.2 and before 1.6.3 are vulnerable to Command Injection via git argument injection. When calling the Pod::Downloader.preprocess_options function and using git, both the git and branch parameters are passed to the git ls-remote subcommand in a way that additional flags can be set. The additional flags can be used to perform a command injection.
Weakness: CWE-88
Which versions are affected by CVE-2022-24440?
4 open source packages ship an affected version, including cocoapods-downloader. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
cocoapods-downloader RubyGems | All versions | 1.6.0 |
cocoapods-downloader RubyGems | All versions | 1.6.0 |
cocoapods-downloader RubyGems | From 1.6.2 | 1.6.3 |
cocoapods-downloader RubyGems | From 1.6.2 | 1.6.3 |
Products include Cocoapods Cocoapods-Downloader.
How do I fix CVE-2022-24440?
Upgrade cocoapods-downloader to a fixed version for your release line: 1.6.0 or 1.6.3.
Upgrade, and pass arguments to programs as a list instead of through a shell. More about Command injection.
Is CVE-2022-24440 being exploited?
There is no known exploitation of CVE-2022-24440 in the wild and no public exploit code.
Other vulnerabilities in cocoapods-downloader
Sources
Also known as GHSA-7627-mp87-jf6q, SNYK-RUBY-COCOAPODSDOWNLOADER-2414278.