{"answers":{"affected":"4 open source packages ship an affected version, including cocoapods-downloader. It affects 1 product.","exploited":"There is no known exploitation of CVE-2022-24440 in the wild and no public exploit code.","fix":"Upgrade cocoapods-downloader to a fixed version for your release line: 1.6.0 or 1.6.3.","what":"CVE-2022-24440 is a high-severity command injection vulnerability in cocoapods-downloader, published on 1 Apr 2022. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2022-24440 and fix it if it is affected.\n\nWhat it is: CVE-2022-24440 is a high-severity command injection vulnerability in cocoapods-downloader, published on 1 Apr 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2022-24440 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- cocoapods-downloader (RubyGems): affected all versions; fixed in 1.6.0\n- cocoapods-downloader (RubyGems): affected all versions; fixed in 1.6.0\n- cocoapods-downloader (RubyGems): affected from 1.6.2; fixed in 1.6.3\n- cocoapods-downloader (RubyGems): affected from 1.6.2; fixed in 1.6.3\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-24440/ (Markdown: https://insights.sbomify.com/CVE-2022-24440/index.md)","id":"CVE-2022-24440","markdown":"https://insights.sbomify.com/CVE-2022-24440/index.md","name":"CVE-2022-24440","record":{"aliases":["GHSA-7627-mp87-jf6q","SNYK-RUBY-COCOAPODSDOWNLOADER-2414278"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Ruby CocoaPods downloader","requires_auth":"none","summary":"Attackers can execute arbitrary commands via git argument injection in the CocoaPods downloader library when processing malicious git or branch parameters.","user_interaction":"not_required","vuln_class":"command_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"snyk","cpe":[{"product":"cocoapods-downloader","vendor":"cocoapods"}],"cvss":{"score":8.1,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-88","name":"Improper Neutralization of Argument Delimiters in a Command"}],"description":"The package cocoapods-downloader before 1.6.0, from 1.6.2 and before 1.6.3 are vulnerable to Command Injection via git argument injection. When calling the Pod::Downloader.preprocess_options function and using git, both the git and branch parameters are passed to the git ls-remote subcommand in a way that additional flags can be set. The additional flags can be used to perform a command injection.","ecosystems":["RubyGems"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Command Injection","id":"CVE-2022-24440","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"RubyGems","product":null,"products":[],"type":"command_injection","year":"2022"},"n_packages":4,"n_references":3,"next":{"headline":"Code Injection","id":"CVE-2022-24441"},"packages":[{"ecosystem":"RubyGems","fixed":["1.6.0"],"introduced":["0"],"last_affected":[],"package":"cocoapods-downloader","purl":null,"source":"GHSA-7627-mp87-jf6q"},{"ecosystem":"RubyGems","fixed":["1.6.0"],"introduced":["0"],"last_affected":[],"package":"cocoapods-downloader","purl":"pkg:gem/cocoapods-downloader","source":"GHSA-7627-mp87-jf6q"},{"ecosystem":"RubyGems","fixed":["1.6.3"],"introduced":["1.6.2"],"last_affected":[],"package":"cocoapods-downloader","purl":null,"source":"GHSA-7627-mp87-jf6q"},{"ecosystem":"RubyGems","fixed":["1.6.3"],"introduced":["1.6.2"],"last_affected":[],"package":"cocoapods-downloader","purl":"pkg:gem/cocoapods-downloader","source":"GHSA-7627-mp87-jf6q"}],"prev":{"headline":"Remote Code Execution (RCE)","id":"CVE-2022-24439"},"products":["cocoapods-downloader"],"published":"2022-04-01","related":[{"cvss_score":8.1,"headline":"Command Injection","id":"CVE-2022-21223","kev_date_added":null,"published":"2022-04-01"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-09-17","vendors":["n/a"]},"summary":"Attackers can execute arbitrary commands via git argument injection in the CocoaPods downloader library when processing malicious git or branch parameters.","url":"https://insights.sbomify.com/CVE-2022-24440/"}