# CVE-2022-24440: Command Injection

> Attackers can execute arbitrary commands via git argument injection in the CocoaPods downloader library when processing malicious git or branch parameters.

- **Severity:** High 8.1 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 1 Apr 2022
- **Updated:** 17 Sep 2024
- **Also known as:** GHSA-7627-mp87-jf6q, SNYK-RUBY-COCOAPODSDOWNLOADER-2414278

## What is CVE-2022-24440?

CVE-2022-24440 is a high-severity command injection vulnerability in cocoapods-downloader, published on 1 Apr 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The package cocoapods-downloader before 1.6.0, from 1.6.2 and before 1.6.3 are vulnerable to Command Injection via git argument injection. When calling the Pod::Downloader.preprocess_options function and using git, both the git and branch parameters are passed to the git ls-remote subcommand in a way that additional flags can be set. The additional flags can be used to perform a command injection.

Weakness: CWE-88 (Improper Neutralization of Argument Delimiters in a Command)

## Which versions are affected by CVE-2022-24440?

4 open source packages ship an affected version, including cocoapods-downloader. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `cocoapods-downloader` | RubyGems | All versions | 1.6.0 |
| `cocoapods-downloader` | RubyGems | All versions | 1.6.0 |
| `cocoapods-downloader` | RubyGems | From 1.6.2 | 1.6.3 |
| `cocoapods-downloader` | RubyGems | From 1.6.2 | 1.6.3 |

Products: Cocoapods Cocoapods-Downloader.

## How do I fix CVE-2022-24440?

Upgrade cocoapods-downloader to a fixed version for your release line: 1.6.0 or 1.6.3.

## Is CVE-2022-24440 being exploited?

There is no known exploitation of CVE-2022-24440 in the wild and no public exploit code.

## Other vulnerabilities in cocoapods-downloader

- [CVE-2022-21223](https://insights.sbomify.com/CVE-2022-21223/): Command Injection (high 8.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-24440 and fix it if it is affected.

What it is: CVE-2022-24440 is a high-severity command injection vulnerability in cocoapods-downloader, published on 1 Apr 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-24440 in the wild and no public exploit code.

Affected packages and fixed versions:
- cocoapods-downloader (RubyGems): affected all versions; fixed in 1.6.0
- cocoapods-downloader (RubyGems): affected all versions; fixed in 1.6.0
- cocoapods-downloader (RubyGems): affected from 1.6.2; fixed in 1.6.3
- cocoapods-downloader (RubyGems): affected from 1.6.2; fixed in 1.6.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-24440/ (Markdown: https://insights.sbomify.com/CVE-2022-24440/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-24440
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-24440
- OSV: https://osv.dev/vulnerability/CVE-2022-24440

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-24440/
Summaries are generated and may contain mistakes; the official description above is the record.
