CVE-2022-24441 Code Injection
Attackers can execute arbitrary code via malicious build files when developers scan untrusted projects with Snyk tools.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2022-24441?
CVE-2022-24441 is a medium-severity code injection vulnerability in snyk, published on 30 Nov 2022. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Official description
The package snyk before 1.1064.0 are vulnerable to Code Injection when analyzing a project. An attacker who can convince a user to scan a malicious project can include commands in a build file such as build.gradle or gradle-wrapper.jar, which will be executed with the privileges of the application. This vulnerability may be triggered when running the the CLI tool directly, or when running a scan with one of the IDE plugins that invoke the Snyk CLI. Successful exploitation of this issue would likely require some level of social engineering - to coerce an untrusted project to be downloaded and analyzed via the Snyk CLI or opened in an IDE where a Snyk IDE plugin is installed and enabled. Additionally, if the IDE has a Trust feature then the target folder must be marked as ‘trusted’ in order to be vulnerable. **NOTE:** This issue is independent of the one reported in [CVE-2022-40764](https://security.snyk.io/vuln/SNYK-JS-SNYK-3037342), and upgrading to a fixed version for this addresses that issue as well. The affected IDE plugins and versions are: - VS Code - Affected: <=1.8.0, Fixed: 1.9.0 - IntelliJ - Affected: <=2.4.47, Fixed: 2.4.48 - Visual Studio - Affected: <=1.1.30, Fixed: 1.1.31 - Eclipse - Affected: <=v20221115.132308, Fixed: All subsequent versions - Language Server - Affected: <=v20221109.114426, Fixed: All subsequent versions
Weakness: CWE-78
Which versions are affected by CVE-2022-24441?
2 open source packages ship an affected version, including snyk. It affects 3 products.
| Package | Affected | Fixed in |
|---|---|---|
snyk npm | All versions | 1.1064.0 |
snyk npm | All versions | 1.1064.0 |
Products include Snyk Snyk Cli, Snyk Snyk Language Server, Snyk Snyk Security.
How do I fix CVE-2022-24441?
Upgrade snyk to 1.1064.0 or later.
Upgrade, and never evaluate templates, expressions or code built from user input. More about Code injection.
Is CVE-2022-24441 being exploited?
There is no known exploitation of CVE-2022-24441 in the wild and no public exploit code.
Other vulnerabilities in snyk
Sources
Also known as GHSA-4vrv-93c7-m92j.