# CVE-2022-24441: Code Injection

> Attackers can execute arbitrary code via malicious build files when developers scan untrusted projects with Snyk tools.

- **Severity:** Medium 5.8 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:C/C:L/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 30 Nov 2022
- **Updated:** 24 Apr 2025
- **Also known as:** GHSA-4vrv-93c7-m92j

## What is CVE-2022-24441?

CVE-2022-24441 is a medium-severity code injection vulnerability in snyk, published on 30 Nov 2022. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

The package snyk before 1.1064.0 are vulnerable to Code Injection when analyzing a project. An attacker who can convince a user to scan a malicious project can include commands in a build file such as build.gradle or gradle-wrapper.jar, which will be executed with the privileges of the application. This vulnerability may be triggered when running the the CLI tool directly, or when running a scan with one of the IDE plugins that invoke the Snyk CLI. Successful exploitation of this issue would likely require some level of social engineering - to coerce an untrusted project to be downloaded and analyzed via the Snyk CLI or opened in an IDE where a Snyk IDE plugin is installed and enabled. Additionally, if the IDE has a Trust feature then the target folder must be marked as ‘trusted’ in order to be vulnerable. **NOTE:** This issue is independent of the one reported in [CVE-2022-40764](https://security.snyk.io/vuln/SNYK-JS-SNYK-3037342), and upgrading to a fixed version for this addresses that issue as well. The affected IDE plugins and versions are: - VS Code - Affected: <=1.8.0, Fixed: 1.9.0 - IntelliJ - Affected: <=2.4.47, Fixed: 2.4.48 - Visual Studio - Affected: <=1.1.30, Fixed: 1.1.31 - Eclipse - Affected: <=v20221115.132308, Fixed: All subsequent versions - Language Server - Affected: <=v20221109.114426, Fixed: All subsequent versions

Weakness: CWE-78 (Improper Neutralization of Special Elements used in an OS Command)

## Which versions are affected by CVE-2022-24441?

2 open source packages ship an affected version, including snyk. It affects 3 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `snyk` | npm | All versions | 1.1064.0 |
| `snyk` | npm | All versions | 1.1064.0 |

Products: Snyk Snyk Cli, Snyk Snyk Language Server, Snyk Snyk Security.

## How do I fix CVE-2022-24441?

Upgrade snyk to 1.1064.0 or later.

## Is CVE-2022-24441 being exploited?

There is no known exploitation of CVE-2022-24441 in the wild and no public exploit code.

## Other vulnerabilities in snyk

- [CVE-2024-48963](https://insights.sbomify.com/CVE-2024-48963/): OS Command Injection in Snyk php plugin (high 7.5)
- [CVE-2024-48964](https://insights.sbomify.com/CVE-2024-48964/): OS Command Injection in Snyk gradle plugin (high 7.5)
- [CVE-2022-22984](https://insights.sbomify.com/CVE-2022-22984/): Command Injection (medium 5.0)
- [CVE-2025-6624](https://insights.sbomify.com/CVE-2025-6624/): Snyk CLI Insertion of Sensitive Information into Log File allowed in DEBUG or DEBUG/TRACE mode (low 2.4)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-24441 and fix it if it is affected.

What it is: CVE-2022-24441 is a medium-severity code injection vulnerability in snyk, published on 30 Nov 2022. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2022-24441 in the wild and no public exploit code.

Affected packages and fixed versions:
- snyk (npm): affected all versions; fixed in 1.1064.0
- snyk (npm): affected all versions; fixed in 1.1064.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-24441/ (Markdown: https://insights.sbomify.com/CVE-2022-24441/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-24441
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-24441
- OSV: https://osv.dev/vulnerability/CVE-2022-24441

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-24441/
Summaries are generated and may contain mistakes; the official description above is the record.
