CVE-2022-24444 Hybridsessions does not expire session id on logout
Silverstripe framework allows session fixation, enabling attackers to hijack user sessions and take over accounts.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2022-24444?
CVE-2022-24444 is a medium-severity vulnerability in Silverstripe Silverstripe, published on 28 Jun 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Silverstripe silverstripe/framework through 4.10 allows Session Fixation.
Weakness: CWE-384
Which versions are affected by CVE-2022-24444?
5 open source packages ship an affected version, including silverstripe/hybridsessions and silverstripe. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
silverstripe/hybridsessions Packagist | From 1.0.0 | 2.4.1 |
silverstripe/hybridsessions Packagist | From 1.0.0 | 2.4.1 |
silverstripe/hybridsessions Packagist | From 2.5.0 | 2.5.1 |
silverstripe/hybridsessions Packagist | From 2.5.0 | 2.5.1 |
silverstripe Bitnami | All versions to 2.5.0 | 2.4.0 |
Products include Silverstripe Silverstripe.
How do I fix CVE-2022-24444?
Upgrade silverstripe/hybridsessions to a fixed version for your release line: 2.4.1 or 2.5.1.
Is CVE-2022-24444 being exploited?
There is no known exploitation of CVE-2022-24444 in the wild and no public exploit code.
Other vulnerabilities in Silverstripe Silverstripe
Sources
Also known as BIT-silverstripe-2022-24444, GHSA-c7q8-m4xw-c674.