# CVE-2022-24450: Incorrect Authorization in NATS nats-server

> Authenticated users can escalate privileges to the System account by misusing dynamically provisioned sandbox accounts in NATS server.

- **Severity:** High 8.8 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 8 Feb 2022
- **Updated:** 3 Aug 2024
- **Also known as:** BIT-nats-2022-24450, GHSA-g6w6-r76c-28j7, GO-2022-0307, MGASA-2022-0225

## What is CVE-2022-24450?

CVE-2022-24450 is a high-severity vulnerability in n/a, published on 8 Feb 2022. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

NATS nats-server before 2.7.2 has Incorrect Access Control. Any authenticated user can obtain the privileges of the System account by misusing the "dynamically provisioned sandbox accounts" feature.

Weakness: CWE-862 (Missing Authorization)

## Which versions are affected by CVE-2022-24450?

8 open source packages ship an affected version, including github.com/nats-io/nats-server/v2, nats and github.com/nats-io/nats-server. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/nats-io/nats-server/v2` | Go | From 2.0.0 | 2.7.2 |
| `github.com/nats-io/nats-server/v2` | Go | From 2.0.0 | 2.7.2 |
| `github.com/nats-io/nats-server/v2` | Go | From 2.0.0 | 2.7.2 |
| `nats` | Bitnami | From 2.0.0 | 2.7.2 |
| `github.com/nats-io/nats-server` | Go | All versions | None |
| `github.com/nats-io/nats-streaming-server` | Go | From 0.15.0 | 0.24.1 |
| `github.com/nats-io/nats-streaming-server` | Go | From 0.15.0 | 0.24.1 |
| `github.com/nats-io/nats-streaming-server` | Go | From 0.15.0 | 0.24.1 |

Products: Linuxfoundation Nats-Server, Nats Nats Streaming Server.

## How do I fix CVE-2022-24450?

Upgrade github.com/nats-io/nats-server/v2 to 2.7.2 or later.

## Is CVE-2022-24450 being exploited?

There is no known exploitation of CVE-2022-24450 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2022-28357](https://insights.sbomify.com/CVE-2022-28357/): NATS nats-server allows directory traversal via unintended path to a management action (critical 9.8)
- [CVE-2026-58253](https://insights.sbomify.com/CVE-2026-58253/): NATS Server: Route API Auth Bypass (high 8.8)
- [CVE-2026-33216](https://insights.sbomify.com/CVE-2026-33216/): NATS has MQTT plaintext password disclosure (high 8.6)
- [CVE-2026-58207](https://insights.sbomify.com/CVE-2026-58207/): NATS Server: Remote crash via integer overflow in Connz pagination (high 7.7)
- [CVE-2026-58210](https://insights.sbomify.com/CVE-2026-58210/): NATS Server: MQTT partial CONNECT packets can exhaust pre-auth memory (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-24450 and fix it if it is affected.

What it is: CVE-2022-24450 is a high-severity vulnerability in n/a, published on 8 Feb 2022. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-24450 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/nats-io/nats-server/v2 (Go): affected from 2.0.0; fixed in 2.7.2
- github.com/nats-io/nats-server/v2 (Go): affected from 2.0.0; fixed in 2.7.2
- github.com/nats-io/nats-server/v2 (Go): affected from 2.0.0; fixed in 2.7.2
- nats (Bitnami): affected from 2.0.0; fixed in 2.7.2
- github.com/nats-io/nats-server (Go): affected all versions; no fix listed
- github.com/nats-io/nats-streaming-server (Go): affected from 0.15.0; fixed in 0.24.1
- github.com/nats-io/nats-streaming-server (Go): affected from 0.15.0; fixed in 0.24.1
- github.com/nats-io/nats-streaming-server (Go): affected from 0.15.0; fixed in 0.24.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-24450/ (Markdown: https://insights.sbomify.com/CVE-2022-24450/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-24450
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-24450
- OSV: https://osv.dev/vulnerability/CVE-2022-24450

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-24450/
Summaries are generated and may contain mistakes; the official description above is the record.
