# CVE-2022-2446: WP Editor <= 1.2.9 - Authenticated (Admin+) PHAR Deserialization

> Authenticated administrators can achieve arbitrary code execution via PHAR deserialization in the WP Editor plugin.

- **Severity:** High 7.2 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 13 Sep 2024
- **Updated:** 8 Apr 2026
- **Also known as:** GHSA-gm45-ppxv-rfjp

## What is CVE-2022-2446?

CVE-2022-2446 is a high-severity unsafe deserialization vulnerability in benjaminprojas WP Editor, published on 13 Sep 2024. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

The WP Editor plugin for WordPress is vulnerable to deserialization of untrusted input via the 'current_theme_root' parameter in versions up to, and including 1.2.9. This makes it possible for authenticated attackers with administrative privileges to call files using a PHAR wrapper that will deserialize and call arbitrary PHP Objects that can be used to perform a variety of malicious actions granted a POP chain is also present. It also requires that the attacker is successful in uploading a file with the serialized payload.

Weakness: CWE-502 (Deserialization of Untrusted Data)

## Which versions are affected by CVE-2022-2446?

It affects 1 product.


Products: Benjaminrojas Wp Editor.

## How do I fix CVE-2022-2446?

No fix has been published for CVE-2022-2446 yet. Limit exposure of the affected software until one is available.

## Is CVE-2022-2446 being exploited?

There is no known exploitation of CVE-2022-2446 in the wild and no public exploit code.

## Other vulnerabilities in benjaminprojas WP Editor

- [CVE-2016-10886](https://insights.sbomify.com/CVE-2016-10886/): Missing authorization in n/a (critical 9.8)
- [CVE-2016-10885](https://insights.sbomify.com/CVE-2016-10885/): Cross-site request forgery in n/a (high 8.8)
- [CVE-2025-3294](https://insights.sbomify.com/CVE-2025-3294/): WP Editor <= 1.2.9.1 - Authenticated (Administrator+) Directory Traversal to Arbitrary File Update (high 7.2)
- [CVE-2021-24151](https://insights.sbomify.com/CVE-2021-24151/): WP Editor < 1.2.7 - Authenticated SQL injection (high 7.2)
- [CVE-2024-25591](https://insights.sbomify.com/CVE-2024-25591/): WordPress WP Editor plugin <=1.2.7 - Sensitive Data Exposure vulnerability (medium 5.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-2446 and fix it if it is affected.

What it is: CVE-2022-2446 is a high-severity unsafe deserialization vulnerability in benjaminprojas WP Editor, published on 13 Sep 2024. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-2446 in the wild and no public exploit code.

Affected product: benjaminprojas WP Editor. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-2446/ (Markdown: https://insights.sbomify.com/CVE-2022-2446/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-2446
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-2446
- OSV: https://osv.dev/vulnerability/CVE-2022-2446

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-2446/
Summaries are generated and may contain mistakes; the official description above is the record.
