CVE-2022-2455 Denial of service in GitLab

Medium 6.5 Published Updated

An authenticated user can exhaust server resources by importing a malicious project, causing denial of service in GitLab.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2022-2455?

CVE-2022-2455 is a medium-severity denial of service vulnerability in Gitlab Gitlab, published on 17 Oct 2022. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

A business logic issue in the handling of large repositories in all versions of GitLab CE/EE from 10.0 before 15.1.6, all versions starting from 15.2 before 15.2.4, all versions starting from 15.3 before 15.3.2 allowed an authenticated and authorized user to exhaust server resources by importing a malicious project.

Weakness: CWE-400

Which versions are affected by CVE-2022-2455?

1 open source package ship an affected version, including gitlab. It affects 1 product.

PackageAffectedFixed in
gitlab BitnamiFrom 10.0.015.1.6, 15.2.4, 15.3.2

Products include Gitlab Gitlab.

How do I fix CVE-2022-2455?

Upgrade gitlab to a fixed version for your release line: 15.1.6, 15.2.4 or 15.3.2.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2022-2455 being exploited?

There is no known exploitation of CVE-2022-2455 in the wild and no public exploit code.

All Gitlab Gitlab vulnerabilities

Sources

Also known as BIT-gitlab-2022-2455, GHSA-fv9w-2hpj-4q5w, UBUNTU-CVE-2022-2455.

Is CVE-2022-2455 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free