# CVE-2022-2455: Denial of service in GitLab

> An authenticated user can exhaust server resources by importing a malicious project, causing denial of service in GitLab.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 17 Oct 2022
- **Updated:** 13 May 2025
- **Also known as:** BIT-gitlab-2022-2455, GHSA-fv9w-2hpj-4q5w, UBUNTU-CVE-2022-2455

## What is CVE-2022-2455?

CVE-2022-2455 is a medium-severity denial of service vulnerability in Gitlab Gitlab, published on 17 Oct 2022. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

A business logic issue in the handling of large repositories in all versions of GitLab CE/EE from 10.0 before 15.1.6, all versions starting from 15.2 before 15.2.4, all versions starting from 15.3 before 15.3.2 allowed an authenticated and authorized user to exhaust server resources by importing a malicious project.

Weakness: CWE-400 (Uncontrolled Resource Consumption)

## Which versions are affected by CVE-2022-2455?

1 open source package ship an affected version, including gitlab. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `gitlab` | Bitnami | From 10.0.0 | 15.1.6, 15.2.4, 15.3.2 |

Products: Gitlab Gitlab.

## How do I fix CVE-2022-2455?

Upgrade gitlab to a fixed version for your release line: 15.1.6, 15.2.4 or 15.3.2.

## Is CVE-2022-2455 being exploited?

There is no known exploitation of CVE-2022-2455 in the wild and no public exploit code.

## Other vulnerabilities in Gitlab Gitlab

- [CVE-2026-97229](https://insights.sbomify.com/CVE-2026-97229/): GitLab Community Edition and Enterprise Edition Integer Overflow or Wraparound (critical 10.0, exploited in the wild)
- [CVE-2026-85706](https://insights.sbomify.com/CVE-2026-85706/): GitLab Community Edition and Enterprise Edition Path Traversal (critical 10.0, exploited in the wild)
- [CVE-2023-7028](https://insights.sbomify.com/CVE-2023-7028/): GitLab Community and Enterprise Editions Improper Access Control (critical 10.0, exploited in the wild)
- [CVE-2021-22205](https://insights.sbomify.com/CVE-2021-22205/): GitLab Community and Enterprise Editions Remote Code Execution (critical 10.0, exploited in the wild)
- [CVE-2021-39935](https://insights.sbomify.com/CVE-2021-39935/): GitLab Community and Enterprise Editions Server-Side Request Forgery (SSRF) (medium 6.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-2455 and fix it if it is affected.

What it is: CVE-2022-2455 is a medium-severity denial of service vulnerability in Gitlab Gitlab, published on 17 Oct 2022. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-2455 in the wild and no public exploit code.

Affected packages and fixed versions:
- gitlab (Bitnami): affected from 10.0.0; fixed in 15.1.6, 15.2.4, 15.3.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-2455/ (Markdown: https://insights.sbomify.com/CVE-2022-2455/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-2455
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-2455
- OSV: https://osv.dev/vulnerability/CVE-2022-2455

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-2455/
Summaries are generated and may contain mistakes; the official description above is the record.
