CVE-2022-2456 Missing authorization in GitLab
Malicious maintainers can alter group or project visibility settings via crafted requests, potentially exposing private data.
- Exploited in the wild
- Not known
- Login needed
- An administrator
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2022-2456?
CVE-2022-2456 is a medium-severity missing authorization vulnerability in Gitlab Gitlab, published on 5 Aug 2022. An attacker needs administrator access to exploit it, with no action from the victim.
Official description
An issue has been discovered in GitLab CE/EE affecting all versions before 15.0.5, all versions starting from 15.1 before 15.1.4, all versions starting from 15.2 before 15.2.1. It may be possible for malicious group or project maintainers to change their corresponding group or project visibility by crafting a malicious POST request.
Which versions are affected by CVE-2022-2456?
1 open source package ship an affected version, including gitlab. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
gitlab Bitnami | All versions | 15.0.5, 15.1.4, 15.2.1 |
Products include Gitlab Gitlab.
How do I fix CVE-2022-2456?
Upgrade gitlab to a fixed version for your release line: 15.0.5, 15.1.4 or 15.2.1.
Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.
Is CVE-2022-2456 being exploited?
There is no known exploitation of CVE-2022-2456 in the wild and no public exploit code.
Other vulnerabilities in Gitlab Gitlab
- CVE-2026-97229 GitLab Community Edition and Enterprise Edition Integer Overflow or Wraparound
- CVE-2026-85706 GitLab Community Edition and Enterprise Edition Path Traversal
- CVE-2023-7028 GitLab Community and Enterprise Editions Improper Access Control
- CVE-2021-22205 GitLab Community and Enterprise Editions Remote Code Execution
- CVE-2021-39935 GitLab Community and Enterprise Editions Server-Side Request Forgery (SSRF)
Sources
Also known as BIT-gitlab-2022-2456, GHSA-57c2-x23h-8mc3, UBUNTU-CVE-2022-2456.