# CVE-2022-24565: Cross-site scripting in n/a

> An attacker can inject malicious scripts via site aliases in Checkmk notifications, potentially leading to session hijacking or code execution.

- **Severity:** Medium 5.4 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 22 Feb 2022
- **Updated:** 3 Aug 2024
- **Also known as:** GHSA-m7q9-gvvr-wx7v, UBUNTU-CVE-2022-24565

## What is CVE-2022-24565?

CVE-2022-24565 is a medium-severity cross-site scripting vulnerability in Checkmk Checkmk, published on 22 Feb 2022. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

Checkmk <=2.0.0p19 Fixed in 2.0.0p20 and Checkmk <=1.6.0p27 Fixed in 1.6.0p28 are affected by a Cross Site Scripting (XSS) vulnerability. The Alias of a site was not properly escaped when shown as condition for notifications.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2022-24565?

It affects 1 product.


Products: Checkmk Checkmk.

## How do I fix CVE-2022-24565?

Apply the vendor's patch.

## Is CVE-2022-24565 being exploited?

There is no known exploitation of CVE-2022-24565 in the wild and no public exploit code.

## Other vulnerabilities in Checkmk Checkmk

- [CVE-2025-39666](https://insights.sbomify.com/CVE-2025-39666/): omd: Local privilege escalation when executing omd commands as root (critical 9.3)
- [CVE-2024-8606](https://insights.sbomify.com/CVE-2024-8606/): Fix 2FA bypass via RestAPI (critical 9.2)
- [CVE-2022-46836](https://insights.sbomify.com/CVE-2022-46836/): PHP code injection in watolib (critical 9.1)
- [CVE-2025-32919](https://insights.sbomify.com/CVE-2025-32919/): Privilege Escalation in Windows License plugin for Checkmk Windows Agent (high 8.8)
- [CVE-2024-28827](https://insights.sbomify.com/CVE-2024-28827/): Privilege escalation in Windows agent (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-24565 and fix it if it is affected.

What it is: CVE-2022-24565 is a medium-severity cross-site scripting vulnerability in Checkmk Checkmk, published on 22 Feb 2022. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2022-24565 in the wild and no public exploit code.

Affected product: Checkmk Checkmk. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-24565/ (Markdown: https://insights.sbomify.com/CVE-2022-24565/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-24565
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-24565
- OSV: https://osv.dev/vulnerability/CVE-2022-24565

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-24565/
Summaries are generated and may contain mistakes; the official description above is the record.
