CVE-2022-24566 Cross-site scripting in n/a

Medium 5.4 Published Updated

An attacker can inject malicious scripts via predefined condition titles in Checkmk, potentially leading to session hijacking or code execution.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
None listed

What is CVE-2022-24566?

CVE-2022-24566 is a medium-severity cross-site scripting vulnerability in Checkmk Checkmk, published on 23 Feb 2022. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

Official description

In Checkmk <=2.0.0p19 fixed in 2.0.0p20 and Checkmk <=1.6.0p27 fixed in 1.6.0p28, the title of a Predefined condition is not properly escaped when shown as condition, which can result in Cross Site Scripting (XSS).

Weakness: CWE-79

Which versions are affected by CVE-2022-24566?

It affects 1 product.

Products include Checkmk Checkmk.

How do I fix CVE-2022-24566?

No fix has been published for CVE-2022-24566 yet. Limit exposure of the affected software until one is available.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2022-24566 being exploited?

There is no known exploitation of CVE-2022-24566 in the wild and no public exploit code.

All Checkmk Checkmk vulnerabilities

Sources

Also known as GHSA-hvm6-7pfm-582j.

Is CVE-2022-24566 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free