# CVE-2022-24614: Allocation of Resources Without Limits or Throttling in metadata-extractor

> Attackers can cause denial of service by triggering excessive memory allocation via crafted JPEG files in the metadata-extractor library.

- **Severity:** Medium 5.5 (`CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 24 Feb 2022
- **Updated:** 3 Aug 2024
- **Also known as:** DEBIAN-CVE-2022-24614, GHSA-4v6p-cxf9-98rf, UBUNTU-CVE-2022-24614

## What is CVE-2022-24614?

CVE-2022-24614 is a medium-severity denial of service vulnerability in n/a, published on 24 Feb 2022. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

### Official description

When reading a specially crafted JPEG file, metadata-extractor up to 2.16.0 can be made to allocate large amounts of memory that finally leads to an out-of-memory error even for very small inputs. This could be used to mount a denial of service attack against services that use metadata-extractor library.

Weakness: CWE-770 (Allocation of Resources Without Limits or Throttling)

## Which versions are affected by CVE-2022-24614?

2 open source packages ship an affected version, including com.drewnoakes:metadata-extractor. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `com.drewnoakes:metadata-extractor` | Maven | All versions | 2.18.0 |
| `com.drewnoakes:metadata-extractor` | Maven | All versions | 2.18.0 |

Products: Metadata-Extractor Project Metadata-Extractor.

## How do I fix CVE-2022-24614?

Upgrade com.drewnoakes:metadata-extractor to 2.18.0 or later.

## Is CVE-2022-24614 being exploited?

There is no known exploitation of CVE-2022-24614 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2022-24613](https://insights.sbomify.com/CVE-2022-24613/): Improper Handling of Exceptional Conditions inn metadata-extractor (medium 5.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-24614 and fix it if it is affected.

What it is: CVE-2022-24614 is a medium-severity denial of service vulnerability in n/a, published on 24 Feb 2022. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2022-24614 in the wild and no public exploit code.

Affected packages and fixed versions:
- com.drewnoakes:metadata-extractor (Maven): affected all versions; fixed in 2.18.0
- com.drewnoakes:metadata-extractor (Maven): affected all versions; fixed in 2.18.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-24614/ (Markdown: https://insights.sbomify.com/CVE-2022-24614/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-24614
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-24614
- OSV: https://osv.dev/vulnerability/CVE-2022-24614

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-24614/
Summaries are generated and may contain mistakes; the official description above is the record.
