{"answers":{"affected":"2 open source packages ship an affected version, including net.lingala.zip4j:zip4j. It affects 1 product.","exploited":"There is no known exploitation of CVE-2022-24615 in the wild and no public exploit code.","fix":"Upgrade net.lingala.zip4j:zip4j to 2.10.0 or later.","what":"CVE-2022-24615 is a medium-severity denial of service vulnerability in n/a, published on 24 Feb 2022. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2022-24615 and fix it if it is affected.\n\nWhat it is: CVE-2022-24615 is a medium-severity denial of service vulnerability in n/a, published on 24 Feb 2022. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2022-24615 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- net.lingala.zip4j:zip4j (Maven): affected all versions; fixed in 2.10.0\n- net.lingala.zip4j:zip4j (Maven): affected all versions; fixed in 2.10.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-24615/ (Markdown: https://insights.sbomify.com/CVE-2022-24615/index.md)","id":"CVE-2022-24615","markdown":"https://insights.sbomify.com/CVE-2022-24615/index.md","name":"CVE-2022-24615","record":{"aliases":["DEBIAN-CVE-2022-24615","GHSA-q62h-jw38-24vh","UBUNTU-CVE-2022-24615"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"Java ZIP library","requires_auth":"none","summary":"Attackers can crash applications using the zip4j library by providing specially crafted ZIP files, causing a denial of service.","user_interaction":"required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"zip4j","vendor":"zip4j_project"}],"cvss":{"score":5.5,"severity":"medium","source":"nvd","vector":"CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H","version":"3.1"},"cwes":[{"id":"CWE-755","name":"Improper Handling of Exceptional Conditions"}],"description":"zip4j up to v2.10.0 can throw various uncaught exceptions while parsing a specially crafted ZIP file, which could result in an application crash. This could be used to mount a denial of service attack against services that use zip4j library.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Uncaught Exception in zip4j","id":"CVE-2022-24615","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"denial_of_service","year":"2022"},"n_packages":2,"n_references":2,"next":{"headline":"Privilege escalation in n/a","id":"CVE-2022-24618"},"packages":[{"ecosystem":"Maven","fixed":["2.10.0"],"introduced":["0"],"last_affected":[],"package":"net.lingala.zip4j:zip4j","purl":null,"source":"GHSA-q62h-jw38-24vh"},{"ecosystem":"Maven","fixed":["2.10.0"],"introduced":["0"],"last_affected":[],"package":"net.lingala.zip4j:zip4j","purl":"pkg:maven/net.lingala.zip4j/zip4j","source":"GHSA-q62h-jw38-24vh"}],"prev":{"headline":"Allocation of Resources Without Limits or Throttling in metadata-extractor","id":"CVE-2022-24614"},"products":["n/a"],"published":"2022-02-24","related":[{"cvss_score":6.5,"headline":"Improper Limitation of a Pathname to a Restricted Directory in Zip4j","id":"CVE-2018-1002202","kev_date_added":null,"published":"2018-07-25"},{"cvss_score":5.9,"headline":"Zip4j Origin Validation Error","id":"CVE-2023-22899","kev_date_added":null,"published":"2023-01-10"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-03","vendors":["n/a"]},"summary":"Attackers can crash applications using the zip4j library by providing specially crafted ZIP files, causing a denial of service.","url":"https://insights.sbomify.com/CVE-2022-24615/"}