# CVE-2022-24615: Uncaught Exception in zip4j

> Attackers can crash applications using the zip4j library by providing specially crafted ZIP files, causing a denial of service.

- **Severity:** Medium 5.5 (`CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 24 Feb 2022
- **Updated:** 3 Aug 2024
- **Also known as:** DEBIAN-CVE-2022-24615, GHSA-q62h-jw38-24vh, UBUNTU-CVE-2022-24615

## What is CVE-2022-24615?

CVE-2022-24615 is a medium-severity denial of service vulnerability in n/a, published on 24 Feb 2022. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

### Official description

zip4j up to v2.10.0 can throw various uncaught exceptions while parsing a specially crafted ZIP file, which could result in an application crash. This could be used to mount a denial of service attack against services that use zip4j library.

Weakness: CWE-755 (Improper Handling of Exceptional Conditions)

## Which versions are affected by CVE-2022-24615?

2 open source packages ship an affected version, including net.lingala.zip4j:zip4j. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `net.lingala.zip4j:zip4j` | Maven | All versions | 2.10.0 |
| `net.lingala.zip4j:zip4j` | Maven | All versions | 2.10.0 |

Products: Zip4j Project Zip4j.

## How do I fix CVE-2022-24615?

Upgrade net.lingala.zip4j:zip4j to 2.10.0 or later.

## Is CVE-2022-24615 being exploited?

There is no known exploitation of CVE-2022-24615 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2018-1002202](https://insights.sbomify.com/CVE-2018-1002202/): Improper Limitation of a Pathname to a Restricted Directory in Zip4j (medium 6.5)
- [CVE-2023-22899](https://insights.sbomify.com/CVE-2023-22899/): Zip4j Origin Validation Error (medium 5.9)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-24615 and fix it if it is affected.

What it is: CVE-2022-24615 is a medium-severity denial of service vulnerability in n/a, published on 24 Feb 2022. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2022-24615 in the wild and no public exploit code.

Affected packages and fixed versions:
- net.lingala.zip4j:zip4j (Maven): affected all versions; fixed in 2.10.0
- net.lingala.zip4j:zip4j (Maven): affected all versions; fixed in 2.10.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-24615/ (Markdown: https://insights.sbomify.com/CVE-2022-24615/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-24615
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-24615
- OSV: https://osv.dev/vulnerability/CVE-2022-24615

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-24615/
Summaries are generated and may contain mistakes; the official description above is the record.
