CVE-2022-24675 Denial of service in n/a
An attacker can cause a stack overflow and crash the application by providing large amounts of PEM data to the Go encoding/pem package.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2022-24675?
CVE-2022-24675 is a high-severity denial of service vulnerability in Fedoraproject Fedora, published on 20 Apr 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
encoding/pem in Go before 1.17.9 and 1.18.x before 1.18.1 has a Decode stack overflow via a large amount of PEM data.
Weakness: CWE-674
Which versions are affected by CVE-2022-24675?
2 open source packages ship an affected version, including golang and stdlib. It affects 3 products.
| Package | Affected | Fixed in |
|---|---|---|
golang Bitnami | All versions | 1.17.9, 1.18.1 |
stdlib Go | All versions | 1.17.9, 1.18.1 |
Products include Fedoraproject Fedora, Golang Go, Netapp Kubernetes Monitoring Operator.
How do I fix CVE-2022-24675?
Upgrade golang to a fixed version for your release line: 1.17.9 or 1.18.1.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2022-24675 being exploited?
There is no known exploitation of CVE-2022-24675 in the wild and no public exploit code.
Public exploit code: 1 proofs of concept on GitHub.
Other vulnerabilities in Fedoraproject Fedora
Sources
Also known as AZL-9527, BIT-golang-2022-24675, GHSA-q42m-q8hq-53rj, GO-2022-0433, UBUNTU-CVE-2022-24675.