# CVE-2022-24683: Arbitrary file reads in HashiCorp Nomad

> Operators with specific capabilities can read arbitrary host files as root, leading to sensitive data exposure and privilege escalation.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 17 Feb 2022
- **Updated:** 3 Aug 2024
- **Also known as:** GHSA-wmrx-57hm-mw7r, GO-2022-0584, UBUNTU-CVE-2022-24683

## What is CVE-2022-24683?

CVE-2022-24683 is a high-severity path traversal vulnerability in n/a, published on 17 Feb 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

HashiCorp Nomad and Nomad Enterprise 0.9.2 through 1.0.17, 1.1.11, and 1.2.5 allow operators with read-fs and alloc-exec (or job-submit) capabilities to read arbitrary files on the host filesystem as root.

## Which versions are affected by CVE-2022-24683?

7 open source packages ship an affected version, including github.com/hashicorp/nomad. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/hashicorp/nomad` | Go | From 0.9.2 | 1.0.18, 1.1.12, 1.2.6 |
| `github.com/hashicorp/nomad` | Go | From 0.9.2 | 1.0.18 |
| `github.com/hashicorp/nomad` | Go | From 0.9.2 | 1.0.18 |
| `github.com/hashicorp/nomad` | Go | From 1.1.0 | 1.1.12 |
| `github.com/hashicorp/nomad` | Go | From 1.1.0 | 1.1.12 |
| `github.com/hashicorp/nomad` | Go | From 1.2.0 | 1.2.6 |
| `github.com/hashicorp/nomad` | Go | From 1.2.0 | 1.2.6 |

Products: Hashicorp Nomad.

## How do I fix CVE-2022-24683?

Upgrade github.com/hashicorp/nomad to a fixed version for your release line: 1.0.18, 1.1.12 or 1.2.6.

## Is CVE-2022-24683 being exploited?

There is no known exploitation of CVE-2022-24683 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2023-1782](https://insights.sbomify.com/CVE-2023-1782/): Nomad Unauthenticated Client Agent HTTP Request Privilege Escalation (critical 10.0)
- [CVE-2022-30324](https://insights.sbomify.com/CVE-2022-30324/): Privilege escalation in Hashicorp Nomad (critical 9.8)
- [CVE-2020-7956](https://insights.sbomify.com/CVE-2020-7956/): Improper Certificate Validation in HashiCorp Nomad (critical 9.8)
- [CVE-2019-12618](https://insights.sbomify.com/CVE-2019-12618/): Hashicorp Nomad Access Control Issues (critical 9.8)
- [CVE-2020-27195](https://insights.sbomify.com/CVE-2020-27195/): Use After Free in HashiCorp Nomad (critical 9.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-24683 and fix it if it is affected.

What it is: CVE-2022-24683 is a high-severity path traversal vulnerability in n/a, published on 17 Feb 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-24683 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/hashicorp/nomad (Go): affected from 0.9.2; fixed in 1.0.18, 1.1.12, 1.2.6
- github.com/hashicorp/nomad (Go): affected from 0.9.2; fixed in 1.0.18
- github.com/hashicorp/nomad (Go): affected from 0.9.2; fixed in 1.0.18
- github.com/hashicorp/nomad (Go): affected from 1.1.0; fixed in 1.1.12
- github.com/hashicorp/nomad (Go): affected from 1.1.0; fixed in 1.1.12
- github.com/hashicorp/nomad (Go): affected from 1.2.0; fixed in 1.2.6
- github.com/hashicorp/nomad (Go): affected from 1.2.0; fixed in 1.2.6

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-24683/ (Markdown: https://insights.sbomify.com/CVE-2022-24683/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-24683
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-24683
- OSV: https://osv.dev/vulnerability/CVE-2022-24683

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-24683/
Summaries are generated and may contain mistakes; the official description above is the record.
