CVE-2022-24684 Nomad Spread Job Stanza May Trigger Panic in Servers

Medium 6.5 Published Updated

Operators with job-submit capabilities can crash server agents using the spread stanza, requiring an upgrade to patched versions.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2022-24684?

CVE-2022-24684 is a medium-severity denial of service vulnerability in n/a, published on 15 Feb 2022. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

HashiCorp Nomad and Nomad Enterprise 0.9.0 through 1.0.16, 1.1.11, and 1.2.5 allow operators with job-submit capabilities to use the spread stanza to panic server agents. Fixed in 1.0.18, 1.1.12, and 1.2.6.

Which versions are affected by CVE-2022-24684?

7 open source packages ship an affected version, including github.com/hashicorp/nomad. It affects 1 product.

PackageAffectedFixed in
github.com/hashicorp/nomad GoFrom 0.9.01.0.18, 1.1.12, 1.2.6
github.com/hashicorp/nomad GoFrom 0.9.01.0.18
github.com/hashicorp/nomad GoFrom 0.9.01.0.18
github.com/hashicorp/nomad GoFrom 1.1.01.1.12
github.com/hashicorp/nomad GoFrom 1.1.01.1.12
github.com/hashicorp/nomad GoFrom 1.2.01.2.6
1 more packages
github.com/hashicorp/nomad GoFrom 1.2.01.2.6

Products include Hashicorp Nomad.

How do I fix CVE-2022-24684?

Upgrade github.com/hashicorp/nomad to a fixed version for your release line: 1.0.18, 1.1.12 or 1.2.6.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2022-24684 being exploited?

There is no known exploitation of CVE-2022-24684 in the wild and no public exploit code.

Sources

Also known as GHSA-6jm6-cmcp-fqjq, GO-2022-0560, UBUNTU-CVE-2022-24684.

Is CVE-2022-24684 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free