CVE-2022-24687 HashiCorp Consul Ingress Gateway Panic Can Shutdown Servers
A user with write permissions can register a malicious service in Consul clusters with Ingress Gateways, causing server panics and denial of service.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2022-24687?
CVE-2022-24687 is a medium-severity denial of service vulnerability in n/a, published on 24 Feb 2022. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
HashiCorp Consul and Consul Enterprise 1.9.0 through 1.9.14, 1.10.7, and 1.11.2 clusters with at least one Ingress Gateway allow a user with service:write to register a specifically-defined service that can cause Consul servers to panic. Fixed in 1.9.15, 1.10.8, and 1.11.3.
Which versions are affected by CVE-2022-24687?
8 open source packages ship an affected version, including github.com/hashicorp/consul and consul. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
github.com/hashicorp/consul Go | From 1.10.0 | 1.10.8 |
github.com/hashicorp/consul Go | From 1.10.0 | 1.10.8 |
github.com/hashicorp/consul Go | From 1.11.0 | 1.11.3 |
github.com/hashicorp/consul Go | From 1.11.0 | 1.11.3 |
github.com/hashicorp/consul Go | From 1.8.0 | 1.9.15, 1.10.8, 1.11.3 |
github.com/hashicorp/consul Go | From 1.8.0 | 1.9.15 |
2 more packages
github.com/hashicorp/consul Go | From 1.8.0 | 1.9.15 |
consul Bitnami | From 1.8.0 | 1.9.15, 1.10.8, 1.11.3 |
Products include Hashicorp Consul.
How do I fix CVE-2022-24687?
Upgrade github.com/hashicorp/consul to a fixed version for your release line: 1.10.8, 1.11.3 or 1.9.15.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2022-24687 being exploited?
There is no known exploitation of CVE-2022-24687 in the wild and no public exploit code.
Other vulnerabilities in n/a
- CVE-2021-41805 Privilege escalation in n/a
- CVE-2021-37219 HashiCorp Consul Privilege Escalation Vulnerability
- CVE-2023-2816 Consul Envoy Extension Downsteam Proxy Configuration By Upstream Service Owner
- CVE-2024-10006 Consul L7 Intentions Vulnerable To Headers Bypass
- CVE-2024-10005 Consul L7 Intentions Vulnerable To URL Path Bypass
Sources
Also known as BIT-consul-2022-24687, DEBIAN-CVE-2022-24687, GHSA-hj93-5fg3-3chr, GO-2022-0953, UBUNTU-CVE-2022-24687.