# CVE-2022-24687: HashiCorp Consul Ingress Gateway Panic Can Shutdown Servers

> A user with write permissions can register a malicious service in Consul clusters with Ingress Gateways, causing server panics and denial of service.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 24 Feb 2022
- **Updated:** 3 Aug 2024
- **Also known as:** BIT-consul-2022-24687, DEBIAN-CVE-2022-24687, GHSA-hj93-5fg3-3chr, GO-2022-0953, UBUNTU-CVE-2022-24687

## What is CVE-2022-24687?

CVE-2022-24687 is a medium-severity denial of service vulnerability in n/a, published on 24 Feb 2022. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

HashiCorp Consul and Consul Enterprise 1.9.0 through 1.9.14, 1.10.7, and 1.11.2 clusters with at least one Ingress Gateway allow a user with service:write to register a specifically-defined service that can cause Consul servers to panic. Fixed in 1.9.15, 1.10.8, and 1.11.3.

## Which versions are affected by CVE-2022-24687?

8 open source packages ship an affected version, including github.com/hashicorp/consul and consul. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/hashicorp/consul` | Go | From 1.10.0 | 1.10.8 |
| `github.com/hashicorp/consul` | Go | From 1.10.0 | 1.10.8 |
| `github.com/hashicorp/consul` | Go | From 1.11.0 | 1.11.3 |
| `github.com/hashicorp/consul` | Go | From 1.11.0 | 1.11.3 |
| `github.com/hashicorp/consul` | Go | From 1.8.0 | 1.9.15, 1.10.8, 1.11.3 |
| `github.com/hashicorp/consul` | Go | From 1.8.0 | 1.9.15 |
| `github.com/hashicorp/consul` | Go | From 1.8.0 | 1.9.15 |
| `consul` | Bitnami | From 1.8.0 | 1.9.15, 1.10.8, 1.11.3 |

Products: Hashicorp Consul.

## How do I fix CVE-2022-24687?

Upgrade github.com/hashicorp/consul to a fixed version for your release line: 1.10.8, 1.11.3 or 1.9.15.

## Is CVE-2022-24687 being exploited?

There is no known exploitation of CVE-2022-24687 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2021-41805](https://insights.sbomify.com/CVE-2021-41805/): Privilege escalation in n/a (high 8.8)
- [CVE-2021-37219](https://insights.sbomify.com/CVE-2021-37219/): HashiCorp Consul Privilege Escalation Vulnerability (high 8.8)
- [CVE-2023-2816](https://insights.sbomify.com/CVE-2023-2816/): Consul Envoy Extension Downsteam Proxy Configuration By Upstream Service Owner (high 8.7)
- [CVE-2024-10006](https://insights.sbomify.com/CVE-2024-10006/): Consul L7 Intentions Vulnerable To Headers Bypass (high 8.3)
- [CVE-2024-10005](https://insights.sbomify.com/CVE-2024-10005/): Consul L7 Intentions Vulnerable To URL Path Bypass (high 8.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-24687 and fix it if it is affected.

What it is: CVE-2022-24687 is a medium-severity denial of service vulnerability in n/a, published on 24 Feb 2022. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-24687 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/hashicorp/consul (Go): affected from 1.10.0; fixed in 1.10.8
- github.com/hashicorp/consul (Go): affected from 1.10.0; fixed in 1.10.8
- github.com/hashicorp/consul (Go): affected from 1.11.0; fixed in 1.11.3
- github.com/hashicorp/consul (Go): affected from 1.11.0; fixed in 1.11.3
- github.com/hashicorp/consul (Go): affected from 1.8.0; fixed in 1.9.15, 1.10.8, 1.11.3
- github.com/hashicorp/consul (Go): affected from 1.8.0; fixed in 1.9.15
- github.com/hashicorp/consul (Go): affected from 1.8.0; fixed in 1.9.15
- consul (Bitnami): affected from 1.8.0; fixed in 1.9.15, 1.10.8, 1.11.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-24687/ (Markdown: https://insights.sbomify.com/CVE-2022-24687/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-24687
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-24687
- OSV: https://osv.dev/vulnerability/CVE-2022-24687

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-24687/
Summaries are generated and may contain mistakes; the official description above is the record.
