{"answers":{"affected":"6 open source packages ship an affected version, including org.apache.kylin:kylin-core-common, org.apache.kylin:kylin-server-base and org.apache.kylin:kylin-spark-project. It affects 1 product.","exploited":"There is no known exploitation of CVE-2022-24697 in the wild and no public exploit code.","fix":"Upgrade org.apache.kylin:kylin-core-common to 4.0.2 or later.","what":"CVE-2022-24697 is a critical command injection vulnerability in Apache Kylin, published on 13 Oct 2022. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2022-24697 and fix it if it is affected.\n\nWhat it is: CVE-2022-24697 is a critical command injection vulnerability in Apache Kylin, published on 13 Oct 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2022-24697 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.apache.kylin:kylin-core-common (Maven): affected all versions; fixed in 4.0.2\n- org.apache.kylin:kylin-core-common (Maven): affected all versions; fixed in 4.0.2\n- org.apache.kylin:kylin-server-base (Maven): affected all versions; fixed in 4.0.2\n- org.apache.kylin:kylin-server-base (Maven): affected all versions; fixed in 4.0.2\n- org.apache.kylin:kylin-spark-project (Maven): affected all versions; fixed in 4.0.2\n- org.apache.kylin:kylin-spark-project (Maven): affected all versions; fixed in 4.0.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-24697/ (Markdown: https://insights.sbomify.com/CVE-2022-24697/index.md)","id":"CVE-2022-24697","markdown":"https://insights.sbomify.com/CVE-2022-24697/index.md","name":"CVE-2022-24697","record":{"aliases":["GHSA-ppxx-m926-g569"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":true,"product_category":"Apache Kylin","requires_auth":"none","summary":"Attackers can execute arbitrary OS commands via command injection in the cube designer when overwriting system parameters in Apache Kylin.","user_interaction":"not_required","vuln_class":"command_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"apache","cpe":[{"product":"kylin","vendor":"apache"}],"cvss":{"score":9.8,"severity":"critical","source":"cisa-adp","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-78","name":"Improper Neutralization of Special Elements used in an OS Command"}],"description":"Kylin's cube designer function has a command injection vulnerability when overwriting system parameters in the configuration overwrites menu. RCE can be implemented by closing the single quotation marks around the parameter value of “-- conf=” to inject any operating system command into the command line parameters. This vulnerability affects Kylin 2 version 2.6.5 and earlier, Kylin 3 version 3.1.2 and earlier, and Kylin 4 version 4.0.1 and earlier.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Apache Kylin vulnerable to remote code execution","id":"CVE-2022-24697","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"command_injection","year":"2022"},"n_packages":6,"n_references":2,"next":{"headline":"Memory corruption in n/a","id":"CVE-2022-24700"},"packages":[{"ecosystem":"Maven","fixed":["4.0.2"],"introduced":["0"],"last_affected":[],"package":"org.apache.kylin:kylin-core-common","purl":null,"source":"GHSA-ppxx-m926-g569"},{"ecosystem":"Maven","fixed":["4.0.2"],"introduced":["0"],"last_affected":[],"package":"org.apache.kylin:kylin-core-common","purl":"pkg:maven/org.apache.kylin/kylin-core-common","source":"GHSA-ppxx-m926-g569"},{"ecosystem":"Maven","fixed":["4.0.2"],"introduced":["0"],"last_affected":[],"package":"org.apache.kylin:kylin-server-base","purl":null,"source":"GHSA-ppxx-m926-g569"},{"ecosystem":"Maven","fixed":["4.0.2"],"introduced":["0"],"last_affected":[],"package":"org.apache.kylin:kylin-server-base","purl":"pkg:maven/org.apache.kylin/kylin-server-base","source":"GHSA-ppxx-m926-g569"},{"ecosystem":"Maven","fixed":["4.0.2"],"introduced":["0"],"last_affected":[],"package":"org.apache.kylin:kylin-spark-project","purl":null,"source":"GHSA-ppxx-m926-g569"},{"ecosystem":"Maven","fixed":["4.0.2"],"introduced":["0"],"last_affected":[],"package":"org.apache.kylin:kylin-spark-project","purl":"pkg:maven/org.apache.kylin/kylin-spark-project","source":"GHSA-ppxx-m926-g569"}],"prev":{"headline":"Mirametrix Glance before 5.1.1.42207 (released on 2018-08-30) allows a local attacker to elevate privileges.","id":"CVE-2022-24696"},"products":["Apache Kylin"],"published":"2022-10-13","related":[{"cvss_score":8.8,"headline":"Apache Kylin OS Command Injection","id":"CVE-2020-1956","kev_date_added":"2022-03-25","published":"2020-05-22"},{"cvss_score":9.8,"headline":"Apache Kylin: SQL Injection Vulnerability in Catalog Cache Refresh API","id":"CVE-2026-62390","kev_date_added":null,"published":"2026-07-14"},{"cvss_score":9.8,"headline":"Apache Kylin: Command injection by Diagnosis Controller","id":"CVE-2022-44621","kev_date_added":null,"published":"2022-12-30"},{"cvss_score":9.8,"headline":"Apache Kylin unsafe class loading","id":"CVE-2021-31522","kev_date_added":null,"published":"2022-01-06"},{"cvss_score":9.8,"headline":"Command injection","id":"CVE-2021-45456","kev_date_added":null,"published":"2022-01-06"},{"cvss_score":9.8,"headline":"Command Injection in Kylin","id":"CVE-2020-13925","kev_date_added":null,"published":"2020-07-14"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2025-05-16","vendors":["Apache Software Foundation"]},"summary":"Attackers can execute arbitrary OS commands via command injection in the cube designer when overwriting system parameters in Apache Kylin.","url":"https://insights.sbomify.com/CVE-2022-24697/"}