# CVE-2022-24697: Apache Kylin vulnerable to remote code execution

> Attackers can execute arbitrary OS commands via command injection in the cube designer when overwriting system parameters in Apache Kylin.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 13 Oct 2022
- **Updated:** 16 May 2025
- **Also known as:** GHSA-ppxx-m926-g569

## What is CVE-2022-24697?

CVE-2022-24697 is a critical command injection vulnerability in Apache Kylin, published on 13 Oct 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Kylin's cube designer function has a command injection vulnerability when overwriting system parameters in the configuration overwrites menu. RCE can be implemented by closing the single quotation marks around the parameter value of “-- conf=” to inject any operating system command into the command line parameters. This vulnerability affects Kylin 2 version 2.6.5 and earlier, Kylin 3 version 3.1.2 and earlier, and Kylin 4 version 4.0.1 and earlier.

Weakness: CWE-78 (Improper Neutralization of Special Elements used in an OS Command)

## Which versions are affected by CVE-2022-24697?

6 open source packages ship an affected version, including org.apache.kylin:kylin-core-common, org.apache.kylin:kylin-server-base and org.apache.kylin:kylin-spark-project. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.kylin:kylin-core-common` | Maven | All versions | 4.0.2 |
| `org.apache.kylin:kylin-core-common` | Maven | All versions | 4.0.2 |
| `org.apache.kylin:kylin-server-base` | Maven | All versions | 4.0.2 |
| `org.apache.kylin:kylin-server-base` | Maven | All versions | 4.0.2 |
| `org.apache.kylin:kylin-spark-project` | Maven | All versions | 4.0.2 |
| `org.apache.kylin:kylin-spark-project` | Maven | All versions | 4.0.2 |

Products: Apache Kylin.

## How do I fix CVE-2022-24697?

Upgrade org.apache.kylin:kylin-core-common to 4.0.2 or later.

## Is CVE-2022-24697 being exploited?

There is no known exploitation of CVE-2022-24697 in the wild and no public exploit code.

## Other vulnerabilities in Apache Kylin

- [CVE-2020-1956](https://insights.sbomify.com/CVE-2020-1956/): Apache Kylin OS Command Injection (high 8.8, exploited in the wild)
- [CVE-2026-62390](https://insights.sbomify.com/CVE-2026-62390/): Apache Kylin: SQL Injection Vulnerability in Catalog Cache Refresh API (critical 9.8)
- [CVE-2022-44621](https://insights.sbomify.com/CVE-2022-44621/): Apache Kylin: Command injection by Diagnosis Controller (critical 9.8)
- [CVE-2021-31522](https://insights.sbomify.com/CVE-2021-31522/): Apache Kylin unsafe class loading (critical 9.8)
- [CVE-2021-45456](https://insights.sbomify.com/CVE-2021-45456/): Command injection (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-24697 and fix it if it is affected.

What it is: CVE-2022-24697 is a critical command injection vulnerability in Apache Kylin, published on 13 Oct 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-24697 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.kylin:kylin-core-common (Maven): affected all versions; fixed in 4.0.2
- org.apache.kylin:kylin-core-common (Maven): affected all versions; fixed in 4.0.2
- org.apache.kylin:kylin-server-base (Maven): affected all versions; fixed in 4.0.2
- org.apache.kylin:kylin-server-base (Maven): affected all versions; fixed in 4.0.2
- org.apache.kylin:kylin-spark-project (Maven): affected all versions; fixed in 4.0.2
- org.apache.kylin:kylin-spark-project (Maven): affected all versions; fixed in 4.0.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-24697/ (Markdown: https://insights.sbomify.com/CVE-2022-24697/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-24697
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-24697
- OSV: https://osv.dev/vulnerability/CVE-2022-24697

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-24697/
Summaries are generated and may contain mistakes; the official description above is the record.
