# CVE-2022-24706: Apache CouchDB Insecure Default Initialization of Resource

> Attackers can bypass authentication on improperly secured CouchDB installations to gain admin privileges and execute code.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Yes, since 25 Aug 2022 (CISA KEV)
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 26 Apr 2022
- **Updated:** 21 Oct 2025
- **Also known as:** BIT-couchdb-2022-24706, GHSA-vxc9-8m8h-9cp6, MGASA-2022-0466

## What is CVE-2022-24706?

CVE-2022-24706 is a critical authentication bypass vulnerability in Apache CouchDB, published on 26 Apr 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

In Apache CouchDB prior to 3.2.2, an attacker can access an improperly secured default installation without authenticating and gain admin privileges. The CouchDB documentation has always made recommendations for properly securing an installation, including recommending using a firewall in front of all CouchDB installations.

Weakness: CWE-1188 (Initialization of a Resource with an Insecure Default)

## Which versions are affected by CVE-2022-24706?

1 open source package ship an affected version, including couchdb. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `couchdb` | Bitnami | All versions | 3.2.2 |

Products: Apache Couchdb.

## How do I fix CVE-2022-24706?

Upgrade couchdb to 3.2.2 or later. US federal agencies must fix it by 15 Sep 2022.

## Is CVE-2022-24706 being exploited?

Yes. Attackers have exploited CVE-2022-24706 in the wild since at least 25 Aug 2022.

Public exploit code:

- Apache CouchDB 3.2.1 - Remote Code Execution (RCE) (github_poc): https://github.com/sadshade/CVE-2022-24706-CouchDB-Exploit
- I wrote a blog post about Apache CouchDB CVE-2022-24706 RCE Exploits (github_poc): https://github.com/ahmetsabrimert/Apache-CouchDB-CVE-2022-24706-RCE-Exploits-Blog-post-
- Apache Couchdb Erlang RCE (metasploit)
- Apache CouchDB 3.2.1 - Remote Code Execution (RCE) (exploitdb)
- CVE-2022-24706 POC exploit (github_poc): https://github.com/superzerosec/CVE-2022-24706
- Apache CouchDB 3.2.1 - Remote Code Execution (RCE) Checker (github_poc): https://github.com/becrevex/CVE-2022-24706

## Other vulnerabilities in Apache CouchDB

- [CVE-2020-1955](https://insights.sbomify.com/CVE-2020-1955/): Auth bypass in Apache CouchDB (critical 9.8)
- [CVE-2017-12635](https://insights.sbomify.com/CVE-2017-12635/): Privilege escalation in Apache CouchDB (critical 9.8)
- [CVE-2018-14889](https://insights.sbomify.com/CVE-2018-14889/): Code injection in n/a (high 7.8)
- [CVE-2016-8742](https://insights.sbomify.com/CVE-2016-8742/): Privilege escalation in Apache CouchDB (high 7.8)
- [CVE-2021-38295](https://insights.sbomify.com/CVE-2021-38295/): Privilege escalation vulnerability when using HTML attachments (high 7.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-24706 and fix it if it is affected.

What it is: CVE-2022-24706 is a critical authentication bypass vulnerability in Apache CouchDB, published on 26 Apr 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: Yes. Attackers have exploited CVE-2022-24706 in the wild since at least 25 Aug 2022.

Affected packages and fixed versions:
- couchdb (Bitnami): affected all versions; fixed in 3.2.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-24706/ (Markdown: https://insights.sbomify.com/CVE-2022-24706/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-24706
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-24706
- OSV: https://osv.dev/vulnerability/CVE-2022-24706

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-24706/
Summaries are generated and may contain mistakes; the official description above is the record.
