{"answers":{"affected":"2 open source packages ship an affected version, including @awsui/components-react. It affects 1 product.","exploited":"There is no known exploitation of CVE-2022-24709 in the wild and no public exploit code.","fix":"Upgrade @awsui/components-react to 3.0.367 or later.","what":"CVE-2022-24709 is a high-severity cross-site scripting vulnerability in awsui-documentation, published on 24 Feb 2022. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2022-24709 and fix it if it is affected.\n\nWhat it is: CVE-2022-24709 is a high-severity cross-site scripting vulnerability in awsui-documentation, published on 24 Feb 2022. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2022-24709 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- @awsui/components-react (npm): affected all versions; fixed in 3.0.367\n- @awsui/components-react (npm): affected all versions; fixed in 3.0.367\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-24709/ (Markdown: https://insights.sbomify.com/CVE-2022-24709/index.md)","id":"CVE-2022-24709","markdown":"https://insights.sbomify.com/CVE-2022-24709/index.md","name":"CVE-2022-24709","record":{"aliases":["GHSA-mf22-92pm-m8p8"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"AWS UI React components","requires_auth":"none","summary":"An attacker can inject JavaScript into AWS UI React components due to improper input neutralization, potentially executing code in user browsers.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"awsui\\/components-react","vendor":"amazon"}],"cvss":{"score":8.8,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"@awsui/components-react is the main AWS UI package which contains React components, with TypeScript definitions designed for user interface development. Multiple components in versions before 3.0.367 have been found to not properly neutralize user input and may allow for javascript injection. Users are advised to upgrade to version 3.0.367 or later. There are no known workarounds for this issue.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Cross site scripting in @awsui/components-react","id":"CVE-2022-24709","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"xss","year":"2022"},"n_packages":2,"n_references":2,"next":{"headline":"Cross-site Scripting in Weblate","id":"CVE-2022-24710"},"packages":[{"ecosystem":"npm","fixed":["3.0.367"],"introduced":["0"],"last_affected":[],"package":"@awsui/components-react","purl":null,"source":"GHSA-mf22-92pm-m8p8"},{"ecosystem":"npm","fixed":["3.0.367"],"introduced":["0"],"last_affected":[],"package":"@awsui/components-react","purl":"pkg:npm/%40awsui/components-react","source":"GHSA-mf22-92pm-m8p8"}],"prev":{"headline":"Stored XSS vulnerability in anuko/timetracker","id":"CVE-2022-24708"},"products":["awsui-documentation"],"published":"2022-02-24","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2025-04-23","vendors":["aws"]},"summary":"An attacker can inject JavaScript into AWS UI React components due to improper input neutralization, potentially executing code in user browsers.","url":"https://insights.sbomify.com/CVE-2022-24709/"}