# CVE-2022-24709: Cross site scripting in @awsui/components-react

> An attacker can inject JavaScript into AWS UI React components due to improper input neutralization, potentially executing code in user browsers.

- **Severity:** High 8.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 24 Feb 2022
- **Updated:** 23 Apr 2025
- **Also known as:** GHSA-mf22-92pm-m8p8

## What is CVE-2022-24709?

CVE-2022-24709 is a high-severity cross-site scripting vulnerability in awsui-documentation, published on 24 Feb 2022. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

@awsui/components-react is the main AWS UI package which contains React components, with TypeScript definitions designed for user interface development. Multiple components in versions before 3.0.367 have been found to not properly neutralize user input and may allow for javascript injection. Users are advised to upgrade to version 3.0.367 or later. There are no known workarounds for this issue.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2022-24709?

2 open source packages ship an affected version, including @awsui/components-react. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@awsui/components-react` | npm | All versions | 3.0.367 |
| `@awsui/components-react` | npm | All versions | 3.0.367 |

Products: Amazon Awsui\/Components-React.

## How do I fix CVE-2022-24709?

Upgrade @awsui/components-react to 3.0.367 or later.

## Is CVE-2022-24709 being exploited?

There is no known exploitation of CVE-2022-24709 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-24709 and fix it if it is affected.

What it is: CVE-2022-24709 is a high-severity cross-site scripting vulnerability in awsui-documentation, published on 24 Feb 2022. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2022-24709 in the wild and no public exploit code.

Affected packages and fixed versions:
- @awsui/components-react (npm): affected all versions; fixed in 3.0.367
- @awsui/components-react (npm): affected all versions; fixed in 3.0.367

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-24709/ (Markdown: https://insights.sbomify.com/CVE-2022-24709/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-24709
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-24709
- OSV: https://osv.dev/vulnerability/CVE-2022-24709

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-24709/
Summaries are generated and may contain mistakes; the official description above is the record.
