CVE-2022-24710 Cross-site Scripting in Weblate
Attackers can execute arbitrary scripts in victim browsers via unsanitized user name and language fields in Weblate.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2022-24710?
CVE-2022-24710 is a medium-severity cross-site scripting vulnerability in WeblateOrg weblate, published on 25 Feb 2022. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Official description
Weblate is a copyleft software web-based continuous localization system. Versions prior to 4.11 do not properly neutralize user input used in user name and language fields. Due to this improper neutralization it is possible to perform cross-site scripting via these fields. The issues were fixed in the 4.11 release. Users unable to upgrade are advised to add their own neutralize logic.
Weakness: CWE-79
Which versions are affected by CVE-2022-24710?
4 open source packages ship an affected version, including weblate and Weblate. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
weblate Bitnami | All versions | 4.11.0 |
weblate PyPI | All versions | 4.11 |
weblate PyPI | All versions | 4.11 |
Weblate PyPI | All versions | 4.11 |
Linux distribution packages (1)
weblate openSUSE:Tumbleweed | All versions | 4.11-1.1 |
Products include Weblate Weblate.
How do I fix CVE-2022-24710?
Upgrade weblate to a fixed version for your release line: 4.11.0 or 4.11.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2022-24710 being exploited?
There is no known exploitation of CVE-2022-24710 in the wild and no public exploit code.
Other vulnerabilities in WeblateOrg weblate
- CVE-2025-68398 Weblate has git config file overwrite vulnerability that leads to remote code execution
- CVE-2026-34393 Weblate: Privilege escalation in the user API endpoint
- CVE-2026-33435 Weblate: Remote code execution during backup restoration
- CVE-2026-34242 Weblate: Arbitrary File Read via Symlink
- CVE-2025-68279 Weblate has an arbitrary file read via symbolic links
Sources
Also known as BIT-weblate-2022-24710, GHSA-6jp6-9rf9-gc66, PYSEC-2022-35, openSUSE-SU-2024:11887-1.