{"answers":{"affected":"4 open source packages ship an affected version, including weblate and Weblate. It affects 1 product.","exploited":"There is no known exploitation of CVE-2022-24710 in the wild and no public exploit code.","fix":"Upgrade weblate to a fixed version for your release line: 4.11.0 or 4.11.","what":"CVE-2022-24710 is a medium-severity cross-site scripting vulnerability in WeblateOrg weblate, published on 25 Feb 2022. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2022-24710 and fix it if it is affected.\n\nWhat it is: CVE-2022-24710 is a medium-severity cross-site scripting vulnerability in WeblateOrg weblate, published on 25 Feb 2022. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2022-24710 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- weblate (Bitnami): affected all versions; fixed in 4.11.0\n- weblate (PyPI): affected all versions; fixed in 4.11\n- weblate (PyPI): affected all versions; fixed in 4.11\n- Weblate (PyPI): affected all versions; fixed in 4.11\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-24710/ (Markdown: https://insights.sbomify.com/CVE-2022-24710/index.md)","id":"CVE-2022-24710","markdown":"https://insights.sbomify.com/CVE-2022-24710/index.md","name":"CVE-2022-24710","record":{"aliases":["BIT-weblate-2022-24710","GHSA-6jp6-9rf9-gc66","PYSEC-2022-35","openSUSE-SU-2024:11887-1"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution","account_takeover"],"network_reachable":"yes","non_default_config":false,"product_category":"Weblate localization system","requires_auth":"low_privilege","summary":"Attackers can execute arbitrary scripts in victim browsers via unsanitized user name and language fields in Weblate.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"weblate","vendor":"weblate"}],"cvss":{"score":5.4,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"Weblate is a copyleft software web-based continuous localization system. Versions prior to 4.11 do not properly neutralize user input used in user name and language fields. Due to this improper neutralization it is possible to perform cross-site scripting via these fields. The issues were fixed in the 4.11 release. Users unable to upgrade are advised to add their own neutralize logic.","ecosystems":["Bitnami","PyPI","openSUSE:Tumbleweed"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Cross-site Scripting in Weblate","id":"CVE-2022-24710","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":null,"products":[],"type":"xss","year":"2022"},"n_packages":5,"n_references":4,"next":{"headline":"Remote CLI Command Execution Vulnerability in CodeIgniter4","id":"CVE-2022-24711"},"packages":[{"ecosystem":"Bitnami","fixed":["4.11.0"],"introduced":["0"],"last_affected":[],"package":"weblate","purl":"pkg:bitnami/weblate","source":"BIT-weblate-2022-24710"},{"ecosystem":"PyPI","fixed":["4.11"],"introduced":["0"],"last_affected":[],"package":"Weblate","purl":null,"source":"GHSA-6jp6-9rf9-gc66"},{"ecosystem":"PyPI","fixed":["4.11"],"introduced":["0"],"last_affected":[],"package":"weblate","purl":"pkg:pypi/weblate","source":"GHSA-6jp6-9rf9-gc66"},{"ecosystem":"PyPI","fixed":["4.11"],"introduced":["0"],"last_affected":[],"package":"weblate","purl":"pkg:pypi/weblate","source":"PYSEC-2022-35"},{"ecosystem":"openSUSE:Tumbleweed","fixed":["4.11-1.1"],"introduced":["0"],"last_affected":[],"package":"weblate","purl":"pkg:rpm/opensuse/weblate\u0026distro=openSUSE%20Tumbleweed","source":"openSUSE-SU-2024:11887-1"}],"prev":{"headline":"Cross site scripting in @awsui/components-react","id":"CVE-2022-24709"},"products":["weblate"],"published":"2022-02-25","related":[{"cvss_score":9.1,"headline":"Weblate has git config file overwrite vulnerability that leads to remote code execution","id":"CVE-2025-68398","kev_date_added":null,"published":"2025-12-18"},{"cvss_score":8.8,"headline":"Weblate: Privilege escalation in the user API endpoint","id":"CVE-2026-34393","kev_date_added":null,"published":"2026-04-15"},{"cvss_score":8.1,"headline":"Weblate: Remote code execution during backup restoration","id":"CVE-2026-33435","kev_date_added":null,"published":"2026-04-15"},{"cvss_score":7.7,"headline":"Weblate: Arbitrary File Read via Symlink","id":"CVE-2026-34242","kev_date_added":null,"published":"2026-04-15"},{"cvss_score":7.7,"headline":"Weblate has an arbitrary file read via symbolic links","id":"CVE-2025-68279","kev_date_added":null,"published":"2025-12-18"},{"cvss_score":7.2,"headline":"Remote Code Execution (RCE)","id":"CVE-2022-23915","kev_date_added":null,"published":"2022-03-04"},{"cvss_score":6.8,"headline":"Weblate: JavaScript localization CDN add-on allows arbitrary local file read outside the repository","id":"CVE-2026-33220","kev_date_added":null,"published":"2026-04-15"}],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"openSUSE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-04-23","vendors":["WeblateOrg"]},"summary":"Attackers can execute arbitrary scripts in victim browsers via unsanitized user name and language fields in Weblate.","url":"https://insights.sbomify.com/CVE-2022-24710/"}