# CVE-2022-24710: Cross-site Scripting in Weblate

> Attackers can execute arbitrary scripts in victim browsers via unsanitized user name and language fields in Weblate.

- **Severity:** Medium 5.4 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 25 Feb 2022
- **Updated:** 23 Apr 2025
- **Also known as:** BIT-weblate-2022-24710, GHSA-6jp6-9rf9-gc66, PYSEC-2022-35, openSUSE-SU-2024:11887-1

## What is CVE-2022-24710?

CVE-2022-24710 is a medium-severity cross-site scripting vulnerability in WeblateOrg weblate, published on 25 Feb 2022. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

Weblate is a copyleft software web-based continuous localization system. Versions prior to 4.11 do not properly neutralize user input used in user name and language fields. Due to this improper neutralization it is possible to perform cross-site scripting via these fields. The issues were fixed in the 4.11 release. Users unable to upgrade are advised to add their own neutralize logic.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2022-24710?

4 open source packages ship an affected version, including weblate and Weblate. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `weblate` | Bitnami | All versions | 4.11.0 |
| `weblate` | PyPI | All versions | 4.11 |
| `weblate` | PyPI | All versions | 4.11 |
| `Weblate` | PyPI | All versions | 4.11 |
| `weblate` | openSUSE:Tumbleweed | All versions | 4.11-1.1 |

Products: Weblate Weblate.

## How do I fix CVE-2022-24710?

Upgrade weblate to a fixed version for your release line: 4.11.0 or 4.11.

## Is CVE-2022-24710 being exploited?

There is no known exploitation of CVE-2022-24710 in the wild and no public exploit code.

## Other vulnerabilities in WeblateOrg weblate

- [CVE-2025-68398](https://insights.sbomify.com/CVE-2025-68398/): Weblate has git config file overwrite vulnerability that leads to remote code execution (critical 9.1)
- [CVE-2026-34393](https://insights.sbomify.com/CVE-2026-34393/): Weblate: Privilege escalation in the user API endpoint (high 8.8)
- [CVE-2026-33435](https://insights.sbomify.com/CVE-2026-33435/): Weblate: Remote code execution during backup restoration (high 8.1)
- [CVE-2026-34242](https://insights.sbomify.com/CVE-2026-34242/): Weblate: Arbitrary File Read via Symlink (high 7.7)
- [CVE-2025-68279](https://insights.sbomify.com/CVE-2025-68279/): Weblate has an arbitrary file read via symbolic links (high 7.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-24710 and fix it if it is affected.

What it is: CVE-2022-24710 is a medium-severity cross-site scripting vulnerability in WeblateOrg weblate, published on 25 Feb 2022. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2022-24710 in the wild and no public exploit code.

Affected packages and fixed versions:
- weblate (Bitnami): affected all versions; fixed in 4.11.0
- weblate (PyPI): affected all versions; fixed in 4.11
- weblate (PyPI): affected all versions; fixed in 4.11
- Weblate (PyPI): affected all versions; fixed in 4.11

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-24710/ (Markdown: https://insights.sbomify.com/CVE-2022-24710/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-24710
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-24710
- OSV: https://osv.dev/vulnerability/CVE-2022-24710

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-24710/
Summaries are generated and may contain mistakes; the official description above is the record.
