{"answers":{"affected":"3 open source packages ship an affected version, including codeigniter4/framework and codeigniter. It affects 1 product.","exploited":"There is no known exploitation of CVE-2022-24711 in the wild and no public exploit code.","fix":"Upgrade codeigniter4/framework to 4.1.9 or later.","what":"CVE-2022-24711 is a critical command injection vulnerability in CodeIgniter4, published on 28 Feb 2022. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2022-24711 and fix it if it is affected.\n\nWhat it is: CVE-2022-24711 is a critical command injection vulnerability in CodeIgniter4, published on 28 Feb 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2022-24711 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- codeigniter4/framework (Packagist): affected all versions; fixed in 4.1.9\n- codeigniter4/framework (Packagist): affected all versions; fixed in 4.1.9\n- codeigniter (Bitnami): affected from 4.0.0; fixed in 4.1.9\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-24711/ (Markdown: https://insights.sbomify.com/CVE-2022-24711/index.md)","id":"CVE-2022-24711","markdown":"https://insights.sbomify.com/CVE-2022-24711/index.md","name":"CVE-2022-24711","record":{"aliases":["BIT-codeigniter-2022-24711","GHSA-xjp4-6w75-qrj7"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"PHP web framework","requires_auth":"none","summary":"Attackers can execute arbitrary CLI commands via HTTP requests due to improper input validation in CodeIgniter4.","user_interaction":"not_required","vuln_class":"command_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"codeigniter","vendor":"codeigniter"}],"cvss":{"score":9.4,"severity":"critical","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-20","name":"Improper Input Validation"}],"description":"CodeIgniter4 is the 4.x branch of CodeIgniter, a PHP full-stack web framework. Prior to version 4.1.9, an improper input validation vulnerability allows attackers to execute CLI routes via HTTP request. Version 4.1.9 contains a patch. There are currently no known workarounds for this vulnerability.","ecosystems":["Bitnami","Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Remote CLI Command Execution Vulnerability in CodeIgniter4","id":"CVE-2022-24711","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":null,"products":[],"type":"command_injection","year":"2022"},"n_packages":3,"n_references":2,"next":{"headline":"Cross-Site Request Forgery (CSRF) Protection Bypass Vulnerability in CodeIgniter4","id":"CVE-2022-24712"},"packages":[{"ecosystem":"Bitnami","fixed":["4.1.9"],"introduced":["4.0.0"],"last_affected":[],"package":"codeigniter","purl":"pkg:bitnami/codeigniter","source":"BIT-codeigniter-2022-24711"},{"ecosystem":"Packagist","fixed":["4.1.9"],"introduced":["0"],"last_affected":[],"package":"codeigniter4/framework","purl":null,"source":"GHSA-xjp4-6w75-qrj7"},{"ecosystem":"Packagist","fixed":["4.1.9"],"introduced":["0"],"last_affected":[],"package":"codeigniter4/framework","purl":"pkg:composer/codeigniter4/framework","source":"GHSA-xjp4-6w75-qrj7"}],"prev":{"headline":"Cross-site Scripting in Weblate","id":"CVE-2022-24710"},"products":["CodeIgniter4"],"published":"2022-02-28","related":[{"cvss_score":9.8,"headline":"CodeIgniter4's ImageMagick Handler has Command Injection Vulnerability","id":"CVE-2025-54418","kev_date_added":null,"published":"2025-07-28"},{"cvss_score":9.8,"headline":"Remote Code Execution Vulnerability in Validation Placeholders","id":"CVE-2023-32692","kev_date_added":null,"published":"2023-05-30"},{"cvss_score":9.8,"headline":"SQL injection in n/a","id":"CVE-2022-40824","kev_date_added":null,"published":"2022-10-07"},{"cvss_score":9.8,"headline":"SQL injection in n/a","id":"CVE-2022-40825","kev_date_added":null,"published":"2022-10-07"},{"cvss_score":9.8,"headline":"SQL injection in n/a","id":"CVE-2022-40826","kev_date_added":null,"published":"2022-10-07"},{"cvss_score":9.8,"headline":"SQL injection in n/a","id":"CVE-2022-40827","kev_date_added":null,"published":"2022-10-07"},{"cvss_score":9.8,"headline":"SQL injection in n/a","id":"CVE-2022-40828","kev_date_added":null,"published":"2022-10-07"}],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-04-23","vendors":["codeigniter4"]},"summary":"Attackers can execute arbitrary CLI commands via HTTP requests due to improper input validation in CodeIgniter4.","url":"https://insights.sbomify.com/CVE-2022-24711/"}