# CVE-2022-24711: Remote CLI Command Execution Vulnerability in CodeIgniter4

> Attackers can execute arbitrary CLI commands via HTTP requests due to improper input validation in CodeIgniter4.

- **Severity:** Critical 9.4 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 28 Feb 2022
- **Updated:** 23 Apr 2025
- **Also known as:** BIT-codeigniter-2022-24711, GHSA-xjp4-6w75-qrj7

## What is CVE-2022-24711?

CVE-2022-24711 is a critical command injection vulnerability in CodeIgniter4, published on 28 Feb 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

CodeIgniter4 is the 4.x branch of CodeIgniter, a PHP full-stack web framework. Prior to version 4.1.9, an improper input validation vulnerability allows attackers to execute CLI routes via HTTP request. Version 4.1.9 contains a patch. There are currently no known workarounds for this vulnerability.

Weakness: CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2022-24711?

3 open source packages ship an affected version, including codeigniter4/framework and codeigniter. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `codeigniter4/framework` | Packagist | All versions | 4.1.9 |
| `codeigniter4/framework` | Packagist | All versions | 4.1.9 |
| `codeigniter` | Bitnami | From 4.0.0 | 4.1.9 |

Products: Codeigniter Codeigniter.

## How do I fix CVE-2022-24711?

Upgrade codeigniter4/framework to 4.1.9 or later.

## Is CVE-2022-24711 being exploited?

There is no known exploitation of CVE-2022-24711 in the wild and no public exploit code.

## Other vulnerabilities in CodeIgniter4

- [CVE-2025-54418](https://insights.sbomify.com/CVE-2025-54418/): CodeIgniter4's ImageMagick Handler has Command Injection Vulnerability (critical 9.8)
- [CVE-2023-32692](https://insights.sbomify.com/CVE-2023-32692/): Remote Code Execution Vulnerability in Validation Placeholders (critical 9.8)
- [CVE-2022-40824](https://insights.sbomify.com/CVE-2022-40824/): SQL injection in n/a (critical 9.8)
- [CVE-2022-40825](https://insights.sbomify.com/CVE-2022-40825/): SQL injection in n/a (critical 9.8)
- [CVE-2022-40826](https://insights.sbomify.com/CVE-2022-40826/): SQL injection in n/a (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-24711 and fix it if it is affected.

What it is: CVE-2022-24711 is a critical command injection vulnerability in CodeIgniter4, published on 28 Feb 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-24711 in the wild and no public exploit code.

Affected packages and fixed versions:
- codeigniter4/framework (Packagist): affected all versions; fixed in 4.1.9
- codeigniter4/framework (Packagist): affected all versions; fixed in 4.1.9
- codeigniter (Bitnami): affected from 4.0.0; fixed in 4.1.9

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-24711/ (Markdown: https://insights.sbomify.com/CVE-2022-24711/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-24711
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-24711
- OSV: https://osv.dev/vulnerability/CVE-2022-24711

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-24711/
Summaries are generated and may contain mistakes; the official description above is the record.
