# CVE-2022-24717: Cross Site Scripting (XSS) in ssr-pages

> An attacker can execute arbitrary scripts via untrusted input in the redirect link property of the ssr-pages library.

- **Severity:** Medium 6.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 1 Mar 2022
- **Updated:** 23 Apr 2025
- **Also known as:** GHSA-7f63-h6g3-7cwm

## What is CVE-2022-24717?

CVE-2022-24717 is a medium-severity cross-site scripting vulnerability in Finastra ssr-pages, published on 1 Mar 2022. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

ssr-pages is an HTML page builder for the purpose of server-side rendering (SSR). In versions prior to 0.1.5, a cross site scripting (XSS) issue can occur when providing untrusted input to the `redirect.link` property as an argument to the `build(MessagePageOptions)` function. While there is no known workaround at this time, there is a patch in version 0.1.5.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2022-24717?

2 open source packages ship an affected version, including @finastra/ssr-pages. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@finastra/ssr-pages` | npm | All versions | 0.1.5 |
| `@finastra/ssr-pages` | npm | All versions | 0.1.5 |

Products: Finastra Ssr-Pages.

## How do I fix CVE-2022-24717?

Upgrade @finastra/ssr-pages to 0.1.5 or later.

## Is CVE-2022-24717 being exploited?

There is no known exploitation of CVE-2022-24717 in the wild and no public exploit code.

## Other vulnerabilities in Finastra ssr-pages

- [CVE-2022-24718](https://insights.sbomify.com/CVE-2022-24718/): Path Traversal in ssr-pages (high 7.6)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-24717 and fix it if it is affected.

What it is: CVE-2022-24717 is a medium-severity cross-site scripting vulnerability in Finastra ssr-pages, published on 1 Mar 2022. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2022-24717 in the wild and no public exploit code.

Affected packages and fixed versions:
- @finastra/ssr-pages (npm): affected all versions; fixed in 0.1.5
- @finastra/ssr-pages (npm): affected all versions; fixed in 0.1.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-24717/ (Markdown: https://insights.sbomify.com/CVE-2022-24717/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-24717
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-24717
- OSV: https://osv.dev/vulnerability/CVE-2022-24717

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-24717/
Summaries are generated and may contain mistakes; the official description above is the record.
