{"answers":{"affected":"2 open source packages ship an affected version, including @finastra/ssr-pages. It affects 1 product.","exploited":"There is no known exploitation of CVE-2022-24718 in the wild and no public exploit code.","fix":"Upgrade @finastra/ssr-pages to 0.1.4 or later.","what":"CVE-2022-24718 is a high-severity path traversal vulnerability in Finastra ssr-pages, published on 1 Mar 2022. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2022-24718 and fix it if it is affected.\n\nWhat it is: CVE-2022-24718 is a high-severity path traversal vulnerability in Finastra ssr-pages, published on 1 Mar 2022. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2022-24718 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- @finastra/ssr-pages (npm): affected all versions; fixed in 0.1.4\n- @finastra/ssr-pages (npm): affected all versions; fixed in 0.1.4\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-24718/ (Markdown: https://insights.sbomify.com/CVE-2022-24718/index.md)","id":"CVE-2022-24718","markdown":"https://insights.sbomify.com/CVE-2022-24718/index.md","name":"CVE-2022-24718","record":{"aliases":["GHSA-w6cx-qg2q-rvq8"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"npm SSR library","requires_auth":"low_privilege","summary":"An attacker can exploit a path traversal vulnerability in the ssr-pages library to read arbitrary files from the server.","user_interaction":"not_required","vuln_class":"path_traversal"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"ssr-pages","vendor":"finastra"}],"cvss":{"score":7.6,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:L/A:L","version":"3.1"},"cwes":[{"id":"CWE-22","name":"Improper Limitation of a Pathname to a Restricted Directory"}],"description":"ssr-pages is an HTML page builder for the purpose of server-side rendering (SSR). In versions prior to 0.1.4, a path traversal issue can occur when providing untrusted input to the `svg` property as an argument to the `build(MessagePageOptions)` function. While there is no known workaround at this time, there is a patch in version 0.1.4.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Path Traversal in ssr-pages","id":"CVE-2022-24718","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"path_traversal","year":"2022"},"n_packages":2,"n_references":3,"next":{"headline":"Unauthorized forwarding of confidential headers in fluture-node","id":"CVE-2022-24719"},"packages":[{"ecosystem":"npm","fixed":["0.1.4"],"introduced":["0"],"last_affected":[],"package":"@finastra/ssr-pages","purl":null,"source":"GHSA-w6cx-qg2q-rvq8"},{"ecosystem":"npm","fixed":["0.1.4"],"introduced":["0"],"last_affected":[],"package":"@finastra/ssr-pages","purl":"pkg:npm/%40finastra/ssr-pages","source":"GHSA-w6cx-qg2q-rvq8"}],"prev":{"headline":"Cross Site Scripting (XSS) in ssr-pages","id":"CVE-2022-24717"},"products":["ssr-pages"],"published":"2022-03-01","related":[{"cvss_score":6.1,"headline":"Cross Site Scripting (XSS) in ssr-pages","id":"CVE-2022-24717","kev_date_added":null,"published":"2022-03-01"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-04-23","vendors":["Finastra"]},"summary":"An attacker can exploit a path traversal vulnerability in the ssr-pages library to read arbitrary files from the server.","url":"https://insights.sbomify.com/CVE-2022-24718/"}