{"answers":{"affected":"2 open source packages ship an affected version, including fluture-node. It affects 1 product.","exploited":"There is no known exploitation of CVE-2022-24719 in the wild and no public exploit code.","fix":"Upgrade fluture-node to 4.0.2 or later.","what":"CVE-2022-24719 is a low-severity vulnerability in fluture-js fluture-node, published on 1 Mar 2022. It can only be exploited from the same machine or local network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2022-24719 and fix it if it is affected.\n\nWhat it is: CVE-2022-24719 is a low-severity vulnerability in fluture-js fluture-node, published on 1 Mar 2022. It can only be exploited from the same machine or local network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2022-24719 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- fluture-node (npm): affected from 4.0.0; fixed in 4.0.2\n- fluture-node (npm): affected from 4.0.0; fixed in 4.0.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-24719/ (Markdown: https://insights.sbomify.com/CVE-2022-24719/index.md)","id":"CVE-2022-24719","markdown":"https://insights.sbomify.com/CVE-2022-24719/index.md","name":"CVE-2022-24719","record":{"aliases":["GHSA-32x6-qvw6-mxj4"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["data_read"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"Node.js HTTP library","requires_auth":"low_privilege","summary":"Attackers can steal confidential headers like Authorization or Cookies when fluture-node follows redirects to third-party domains or unencrypted HTTP.","user_interaction":"not_required","vuln_class":"information_disclosure"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"fluture-node","vendor":"fluture-node_project"}],"cvss":{"score":2.6,"severity":"low","source":"cna","vector":"CVSS:3.1/AV:A/AC:H/PR:L/UI:N/S:U/C:L/I:N/A:N","version":"3.1"},"cwes":[{"id":"CWE-212","name":"Improper Removal of Sensitive Information Before Storage or Transfer"},{"id":"CWE-359","name":"Exposure of Private Personal Information to an Unauthorized Actor"}],"description":"Fluture-Node is a FP-style HTTP and streaming utils for Node based on Fluture. Using `followRedirects` or `followRedirectsWith` with any of the redirection strategies built into fluture-node 4.0.0 or 4.0.1, paired with a request that includes confidential headers such as Authorization or Cookie, exposes you to a vulnerability where, if the destination server were to redirect the request to a server on a third-party domain, or the same domain over unencrypted HTTP, the headers would be included in the follow-up request and be exposed to the third party, or potential http traffic sniffing. The redirection strategies made available in version 4.0.2 automatically redact confidential headers when a redirect is followed across to another origin. A workaround has been identified by using a custom redirection strategy via the `followRedirectsWith` function. The custom strategy can be based on the new strategies available in fluture-node@4.0.2.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Unauthorized forwarding of confidential headers in fluture-node","id":"CVE-2022-24719","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"information_disclosure","year":"2022"},"n_packages":2,"n_references":4,"next":{"headline":"Improper Input Validation in image_processing","id":"CVE-2022-24720"},"packages":[{"ecosystem":"npm","fixed":["4.0.2"],"introduced":["4.0.0"],"last_affected":[],"package":"fluture-node","purl":null,"source":"GHSA-32x6-qvw6-mxj4"},{"ecosystem":"npm","fixed":["4.0.2"],"introduced":["4.0.0"],"last_affected":[],"package":"fluture-node","purl":"pkg:npm/fluture-node","source":"GHSA-32x6-qvw6-mxj4"}],"prev":{"headline":"Path Traversal in ssr-pages","id":"CVE-2022-24718"},"products":["fluture-node"],"published":"2022-03-01","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-04-23","vendors":["fluture-js"]},"summary":"Attackers can steal confidential headers like Authorization or Cookies when fluture-node follows redirects to third-party domains or unencrypted HTTP.","url":"https://insights.sbomify.com/CVE-2022-24719/"}