# CVE-2022-24719: Unauthorized forwarding of confidential headers in fluture-node

> Attackers can steal confidential headers like Authorization or Cookies when fluture-node follows redirects to third-party domains or unencrypted HTTP.

- **Severity:** Low 2.6 (`CVSS:3.1/AV:A/AC:H/PR:L/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 1 Mar 2022
- **Updated:** 23 Apr 2025
- **Also known as:** GHSA-32x6-qvw6-mxj4

## What is CVE-2022-24719?

CVE-2022-24719 is a low-severity vulnerability in fluture-js fluture-node, published on 1 Mar 2022. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

Fluture-Node is a FP-style HTTP and streaming utils for Node based on Fluture. Using `followRedirects` or `followRedirectsWith` with any of the redirection strategies built into fluture-node 4.0.0 or 4.0.1, paired with a request that includes confidential headers such as Authorization or Cookie, exposes you to a vulnerability where, if the destination server were to redirect the request to a server on a third-party domain, or the same domain over unencrypted HTTP, the headers would be included in the follow-up request and be exposed to the third party, or potential http traffic sniffing. The redirection strategies made available in version 4.0.2 automatically redact confidential headers when a redirect is followed across to another origin. A workaround has been identified by using a custom redirection strategy via the `followRedirectsWith` function. The custom strategy can be based on the new strategies available in fluture-node@4.0.2.

Weakness: CWE-212 (Improper Removal of Sensitive Information Before Storage or Transfer), CWE-359 (Exposure of Private Personal Information to an Unauthorized Actor)

## Which versions are affected by CVE-2022-24719?

2 open source packages ship an affected version, including fluture-node. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `fluture-node` | npm | From 4.0.0 | 4.0.2 |
| `fluture-node` | npm | From 4.0.0 | 4.0.2 |

Products: Fluture-Node Project Fluture-Node.

## How do I fix CVE-2022-24719?

Upgrade fluture-node to 4.0.2 or later.

## Is CVE-2022-24719 being exploited?

There is no known exploitation of CVE-2022-24719 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-24719 and fix it if it is affected.

What it is: CVE-2022-24719 is a low-severity vulnerability in fluture-js fluture-node, published on 1 Mar 2022. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-24719 in the wild and no public exploit code.

Affected packages and fixed versions:
- fluture-node (npm): affected from 4.0.0; fixed in 4.0.2
- fluture-node (npm): affected from 4.0.0; fixed in 4.0.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-24719/ (Markdown: https://insights.sbomify.com/CVE-2022-24719/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-24719
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-24719
- OSV: https://osv.dev/vulnerability/CVE-2022-24719

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-24719/
Summaries are generated and may contain mistakes; the official description above is the record.
