# CVE-2022-24720: Improper Input Validation in image_processing

> Attackers can execute shell commands via unsanitized user input in image_processing operations, affecting Active Storage users.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 1 Mar 2022
- **Updated:** 22 Apr 2025
- **Also known as:** DEBIAN-CVE-2022-24720, DSA-5310-1, GHSA-cxf7-qrc5-9446, UBUNTU-CVE-2022-24720, USN-6675-1

## What is CVE-2022-24720?

CVE-2022-24720 is a critical command injection vulnerability in Debian Debian Linux, published on 1 Mar 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

image_processing is an image processing wrapper for libvips and ImageMagick/GraphicsMagick. Prior to version 1.12.2, using the `#apply` method from image_processing to apply a series of operations that are coming from unsanitized user input allows the attacker to execute shell commands. This method is called internally by Active Storage variants, so Active Storage is vulnerable as well. The vulnerability has been fixed in version 1.12.2 of image_processing. As a workaround, users who process based on user input should always sanitize the user input by allowing only a constrained set of operations.

Weakness: CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2022-24720?

2 open source packages ship an affected version, including image_processing. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `image_processing` | RubyGems | All versions | 1.12.2 |
| `image_processing` | RubyGems | All versions | 1.12.2 |

Products: Debian Debian Linux, Image Processing Project Image Processing.

## How do I fix CVE-2022-24720?

Upgrade image_processing to 1.12.2 or later.

## Is CVE-2022-24720 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-24720 exists.

## Other vulnerabilities in Debian Debian Linux

- [CVE-2015-3306](https://insights.sbomify.com/CVE-2015-3306/): ProFTPD Improper Access Control (critical 10.0, exploited in the wild)
- [CVE-2025-49113](https://insights.sbomify.com/CVE-2025-49113/): RoundCube Webmail Deserialization of Untrusted Data (critical 9.9, exploited in the wild)
- [CVE-2026-24061](https://insights.sbomify.com/CVE-2026-24061/): GNU InetUtils Argument Injection (critical 9.8, exploited in the wild)
- [CVE-2025-39682](https://insights.sbomify.com/CVE-2025-39682/): Linux Kernel Improper Check for Unusual or Exceptional Conditions (critical 9.8, exploited in the wild)
- [CVE-2024-9680](https://insights.sbomify.com/CVE-2024-9680/): Mozilla Firefox Use-After-Free (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-24720 and fix it if it is affected.

What it is: CVE-2022-24720 is a critical command injection vulnerability in Debian Debian Linux, published on 1 Mar 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-24720 exists.

Affected packages and fixed versions:
- image_processing (RubyGems): affected all versions; fixed in 1.12.2
- image_processing (RubyGems): affected all versions; fixed in 1.12.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-24720/ (Markdown: https://insights.sbomify.com/CVE-2022-24720/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-24720
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-24720
- OSV: https://osv.dev/vulnerability/CVE-2022-24720

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-24720/
Summaries are generated and may contain mistakes; the official description above is the record.
