# CVE-2022-24721: Incorrect Authorization in org.cometd.oort

> Remote attackers can subscribe to internal channels to read sensitive data or publish to modify user data and cluster structure in CometD.

- **Severity:** High 8.1 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 15 Mar 2022
- **Updated:** 23 Apr 2025
- **Also known as:** GHSA-rjmq-6v55-4rjv

## What is CVE-2022-24721?

CVE-2022-24721 is a high-severity missing authorization vulnerability in cometd, published on 15 Mar 2022. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

CometD is a scalable comet implementation for web messaging. In any version prior to 5.0.11, 6.0.6, and 7.0.6, internal usage of Oort and Seti channels is improperly authorized, so any remote user could subscribe and publish to those channels. By subscribing to those channels, a remote user may be able to watch cluster-internal traffic that contains other users' (possibly sensitive) data. By publishing to those channels, a remote user may be able to create/modify/delete other user's data and modify the cluster structure. A fix is available in versions 5.0.11, 6.0.6, and 7.0.6. As a workaround, install a custom `SecurityPolicy` that forbids subscription and publishing to remote, non-Oort, sessions on Oort and Seti channels.

Weakness: CWE-863 (Incorrect Authorization)

## Which versions are affected by CVE-2022-24721?

6 open source packages ship an affected version, including org.cometd.java:cometd-java-oort. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.cometd.java:cometd-java-oort` | Maven | All versions | 5.0.11 |
| `org.cometd.java:cometd-java-oort` | Maven | All versions | 5.0.11 |
| `org.cometd.java:cometd-java-oort` | Maven | From 6.0.0 | 6.0.6 |
| `org.cometd.java:cometd-java-oort` | Maven | From 6.0.0 | 6.0.6 |
| `org.cometd.java:cometd-java-oort` | Maven | From 7.0.0 | 7.0.6 |
| `org.cometd.java:cometd-java-oort` | Maven | From 7.0.0 | 7.0.6 |

Products: Cometd Cometd.

## How do I fix CVE-2022-24721?

Upgrade org.cometd.java:cometd-java-oort to a fixed version for your release line: 5.0.11, 6.0.6 or 7.0.6.

## Is CVE-2022-24721 being exploited?

There is no known exploitation of CVE-2022-24721 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-24721 and fix it if it is affected.

What it is: CVE-2022-24721 is a high-severity missing authorization vulnerability in cometd, published on 15 Mar 2022. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-24721 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.cometd.java:cometd-java-oort (Maven): affected all versions; fixed in 5.0.11
- org.cometd.java:cometd-java-oort (Maven): affected all versions; fixed in 5.0.11
- org.cometd.java:cometd-java-oort (Maven): affected from 6.0.0; fixed in 6.0.6
- org.cometd.java:cometd-java-oort (Maven): affected from 6.0.0; fixed in 6.0.6
- org.cometd.java:cometd-java-oort (Maven): affected from 7.0.0; fixed in 7.0.6
- org.cometd.java:cometd-java-oort (Maven): affected from 7.0.0; fixed in 7.0.6

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-24721/ (Markdown: https://insights.sbomify.com/CVE-2022-24721/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-24721
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-24721
- OSV: https://osv.dev/vulnerability/CVE-2022-24721

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-24721/
Summaries are generated and may contain mistakes; the official description above is the record.
